SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

29
devel/py-rencode/Makefile Normal file
View file

@ -0,0 +1,29 @@
COMMENT = module for fast object serialization similar to bencode
MODPY_EGG_VERSION = 1.0.6
DISTNAME = rencode-${MODPY_EGG_VERSION}
PKGNAME = py-${DISTNAME}
REVISION = 6
CATEGORIES = devel
HOMEPAGE = https://github.com/aresch/rencode
# GPLv3
PERMIT_PACKAGE = Yes
FLAVORS = python3
FLAVOR = python3
MODULES = lang/python
MODPY_PI = Yes
MODPY_PYBUILD = setuptools
WANTLIB += pthread ${MODPY_WANTLIB}
BUILD_DEPENDS = devel/py-wheel${MODPY_FLAVOR}
pre-test:
cp ${WRKSRC}/${MODPY_TEST_LIBDIR}/rencode/*.so ${WRKSRC}/rencode
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (rencode-1.0.6.tar.gz) = JYZDXE6n1F904mdlrTPXUwnefPR8TXYujvq9OZBcBxg=
SIZE (rencode-1.0.6.tar.gz) = 74660

View file

@ -0,0 +1,22 @@
Avoid cython due to build error:
ValueError: 'rencode/rencode.pyx' doesn't match any files
Remove platform specific optimizations.
Index: setup.py
--- setup.py.orig
+++ setup.py
@@ -36,12 +36,12 @@ except ImportError as ex:
from setuptools.command.build_ext import build_ext
cythonize = False
+cythonize = False
source_ext = ".pyx" if cythonize else ".c"
ext_modules = [
Extension(
"rencode._rencode",
- extra_compile_args=["-O3"],
sources=["rencode/rencode" + source_ext],
),
]

View file

@ -0,0 +1,6 @@
The rencode module is similar to bencode from the BitTorrent project.
For complex, heterogeneous data structures with many small elements,
r-encodings take up significantly less space than b-encodings. This
version of rencode is a complete rewrite in Cython to attempt to
increase the performance over the pure Python module written by
Petru Paler, Connelly Barnes et al.

View file

@ -0,0 +1,16 @@
@pkgpath devel/py-rencode
lib/python${MODPY_VERSION}/site-packages/rencode/
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/COPYING
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/METADATA
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/RECORD
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/WHEEL
lib/python${MODPY_VERSION}/site-packages/rencode-${MODPY_EGG_VERSION}.dist-info/top_level.txt
lib/python${MODPY_VERSION}/site-packages/rencode/__init__.py
${MODPY_COMMENT}lib/python${MODPY_VERSION}/site-packages/rencode/${MODPY_PYCACHE}/
lib/python${MODPY_VERSION}/site-packages/rencode/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
lib/python${MODPY_VERSION}/site-packages/rencode/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
lib/python${MODPY_VERSION}/site-packages/rencode/${MODPY_PYCACHE}rencode_orig.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
lib/python${MODPY_VERSION}/site-packages/rencode/${MODPY_PYCACHE}rencode_orig.${MODPY_PYC_MAGIC_TAG}pyc
@so lib/python${MODPY_VERSION}/site-packages/rencode/_rencode.${MODPY_PYC_MAGIC_TAG}so
lib/python${MODPY_VERSION}/site-packages/rencode/rencode_orig.py