SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,13 @@
Index: setup.py
--- setup.py.orig
+++ setup.py
@@ -82,9 +82,6 @@ if not any(arg in sys.argv for arg in ['clean', 'check
compiler_directives = {}
if 'CYTHON_TRACE' in sys.argv:
compiler_directives['linetrace'] = True
- # Set CFLAG to all optimizations (-O3), add `-g0` to reduce size of binaries, see #2276
- # Any additional CFLAGS will be appended. Only the last optimization flag will have effect
- os.environ['CFLAGS'] = '-O3 -g0 ' + os.environ.get('CFLAGS', '')
ext_modules = cythonize(
'pydantic/*.py',
exclude=['pydantic/generics.py'],