SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
25
devel/py-ipykernel/patches/patch-setup_py
Normal file
25
devel/py-ipykernel/patches/patch-setup_py
Normal file
|
@ -0,0 +1,25 @@
|
|||
Index: setup.py
|
||||
--- setup.py.orig
|
||||
+++ setup.py
|
||||
@@ -87,21 +87,6 @@ install_requires = setuptools_args['install_requires']
|
||||
'tornado>=4.0',
|
||||
]
|
||||
|
||||
-if any(a.startswith(('bdist', 'build', 'install')) for a in sys.argv):
|
||||
- from ipykernel.kernelspec import write_kernel_spec, make_ipkernel_cmd, KERNEL_NAME
|
||||
-
|
||||
- argv = make_ipkernel_cmd(executable='python')
|
||||
- dest = os.path.join(here, 'data_kernelspec')
|
||||
- if os.path.exists(dest):
|
||||
- shutil.rmtree(dest)
|
||||
- write_kernel_spec(dest, overrides={'argv': argv})
|
||||
-
|
||||
- setup_args['data_files'] = [
|
||||
- (pjoin('share', 'jupyter', 'kernels', KERNEL_NAME),
|
||||
- glob(pjoin('data_kernelspec', '*'))),
|
||||
- ]
|
||||
-
|
||||
-
|
||||
setuptools_args['python_requires'] = '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*'
|
||||
|
||||
extras_require = setuptools_args['extras_require'] = {
|
Loading…
Add table
Add a link
Reference in a new issue