SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

17
devel/p5-IPC-Run/Makefile Normal file
View file

@ -0,0 +1,17 @@
COMMENT = run a subprocess
DISTNAME = IPC-Run-20200505.0
CATEGORIES = devel
# Perl
PERMIT_PACKAGE = Yes
MODULES = cpan
RUN_DEPENDS = devel/p5-IO-Tty>=1.08
TEST_DEPENDS = devel/p5-Readonly
PKG_ARCH = *
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (IPC-Run-20200505.0.tar.gz) = gW6/IX+g35nFg9c8Csxs7XisdzeHxmTHXL8UC7fkyQE=
SIZE (IPC-Run-20200505.0.tar.gz) = 127505

View file

@ -0,0 +1,16 @@
Make t/pty.t test pass on OpenBSD.
Index: t/pty.t
--- t/pty.t.orig
+++ t/pty.t
@@ -141,6 +141,10 @@ SKIP: {
is( _map_fds, $fd_map );
}
+# OpenBSD libc devname(3) opens /var/run/dev.db and keeps it open.
+# As this would confuse open file descriptor checks, open it in advance.
+IO::Pty->new();
+
##
## stdout, stderr
##

View file

@ -0,0 +1,8 @@
IPC::Run allows you run and interact with child processes
using files, pipes, and pseudo-ttys. Both system()-style
and scripted usages are supported and may be mixed. Like-
wise, functional and OO API styles are both supported and
may be mixed.
This is an heavy-weight module. Refer to IPC::Run3 to run
simple stuff with io redirections.

View file

@ -0,0 +1,16 @@
${P5SITE}/IPC/
${P5SITE}/IPC/Run/
${P5SITE}/IPC/Run.pm
${P5SITE}/IPC/Run/Debug.pm
${P5SITE}/IPC/Run/IO.pm
${P5SITE}/IPC/Run/Timer.pm
${P5SITE}/IPC/Run/Win32Helper.pm
${P5SITE}/IPC/Run/Win32IO.pm
${P5SITE}/IPC/Run/Win32Pump.pm
@man man/man3p/IPC::Run.3p
@man man/man3p/IPC::Run::Debug.3p
@man man/man3p/IPC::Run::IO.3p
@man man/man3p/IPC::Run::Timer.3p
@man man/man3p/IPC::Run::Win32Helper.3p
@man man/man3p/IPC::Run::Win32IO.3p
@man man/man3p/IPC::Run::Win32Pump.3p