SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,30 @@
COMMENT = manipulate file metadata
DISTNAME = File-Attributes-0.04
REVISION = 6
CATEGORIES = devel
MAINTAINER = Alexander Bluhm <bluhm@openbsd.org>
# Perl
PERMIT_PACKAGE = Yes
MODULES = cpan
RUN_DEPENDS = devel/p5-Best>=0.06 \
devel/p5-Module-Pluggable \
devel/p5-YAML \
devel/p5-YAML-Syck
TEST_DEPENDS = devel/p5-Directory-Scratch>=0.05 \
devel/p5-Test-Pod>=1.14 \
devel/p5-Test-Pod-Coverage>=1.04
CONFIGURE_STYLE = modinst
PKG_ARCH = *
# modinst uses devel/p5-Module-Install, ensure we do not use inc
post-extract:
rm -rf -- ${WRKDIST}/inc
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (File-Attributes-0.04.tar.gz) = FUngXqC32quXIZNDGGgg6we8tg+i9nXyMYmQOJXxRhE=
SIZE (File-Attributes-0.04.tar.gz) = 30374

View file

@ -0,0 +1,14 @@
https://rt.cpan.org/Public/Bug/Display.html?id=56221
Index: t/lib/File/Attributes/Test.pm
--- t/lib/File/Attributes/Test.pm.orig
+++ t/lib/File/Attributes/Test.pm
@@ -6,7 +6,7 @@
package File::Attributes::Test;
use base 'File::Attributes::Base';
our $VERSION =
- 'foo-o-matic';
+ '42';
my %attributes;
my $IGNORE = qr/NONONO/;

View file

@ -0,0 +1,4 @@
File::Attributes is a wrapper around modules in the File::Attributes
hierarchy. If you use this module directly (instead of one of the
aforementioned descendants), then your attribute manipulations will Just
Work, regardless of the underlying filesystem.

View file

@ -0,0 +1,8 @@
${P5SITE}/File/
${P5SITE}/File/Attributes/
${P5SITE}/File/Attributes.pm
${P5SITE}/File/Attributes/Base.pm
${P5SITE}/File/Attributes/Simple.pm
@man man/man3p/File::Attributes.3p
@man man/man3p/File::Attributes::Base.3p
@man man/man3p/File::Attributes::Simple.3p