SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
21
devel/p5-Data-Visitor/Makefile
Normal file
21
devel/p5-Data-Visitor/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
COMMENT= visitor-style traversal of Perl data structures
|
||||
|
||||
MODULES= cpan
|
||||
PKG_ARCH= *
|
||||
DISTNAME= Data-Visitor-0.30
|
||||
CATEGORIES= devel
|
||||
REVISION= 0
|
||||
|
||||
# perl
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
RUN_DEPENDS= devel/p5-Class-Load>=0.06 \
|
||||
devel/p5-Moose>=0.89 \
|
||||
devel/p5-Task-Weaken \
|
||||
devel/p5-Tie-ToObject>=0.01 \
|
||||
devel/p5-namespace-clean>=0.19
|
||||
|
||||
TEST_DEPENDS= devel/p5-Test-Requires \
|
||||
devel/p5-Test-Script>=1.05
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/p5-Data-Visitor/distinfo
Normal file
2
devel/p5-Data-Visitor/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (Data-Visitor-0.30.tar.gz) = jqJKvMNlnnYKqUruK6fdVMrK8gMCcFUkFD85VUAJ7VQ=
|
||||
SIZE (Data-Visitor-0.30.tar.gz) = 24542
|
15
devel/p5-Data-Visitor/patches/patch-lib_Data_Visitor_pm
Normal file
15
devel/p5-Data-Visitor/patches/patch-lib_Data_Visitor_pm
Normal file
|
@ -0,0 +1,15 @@
|
|||
Data::Alias is broken with Perl 5.24.1, do not use it.
|
||||
https://rt.cpan.org/Public/Bug/Display.html?id=118854
|
||||
|
||||
Index: lib/Data/Visitor.pm
|
||||
--- lib/Data/Visitor.pm.orig
|
||||
+++ lib/Data/Visitor.pm
|
||||
@@ -22,7 +22,7 @@ use namespace::clean -except => 'meta';
|
||||
# the double not makes this no longer undef, so exempt from useless constant warnings in older perls
|
||||
use constant DEBUG => not not our $DEBUG || $ENV{DATA_VISITOR_DEBUG};
|
||||
|
||||
-use constant HAS_DATA_ALIAS => load_optional_class('Data::Alias');
|
||||
+use constant HAS_DATA_ALIAS => 0;
|
||||
|
||||
has tied_as_objects => (
|
||||
isa => "Bool",
|
12
devel/p5-Data-Visitor/patches/patch-t_weak_t
Normal file
12
devel/p5-Data-Visitor/patches/patch-t_weak_t
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: t/weak.t
|
||||
--- t/weak.t.orig
|
||||
+++ t/weak.t
|
||||
@@ -3,7 +3,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
|
||||
-use Test::More;
|
||||
+use Test::More skip_all => 'Data::Alias is broken';
|
||||
|
||||
use Test::Requires 'Data::Alias';
|
||||
|
1
devel/p5-Data-Visitor/pkg/DESCR
Normal file
1
devel/p5-Data-Visitor/pkg/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
This module is a simple visitor implementation for Perl values.
|
5
devel/p5-Data-Visitor/pkg/PLIST
Normal file
5
devel/p5-Data-Visitor/pkg/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
${P5SITE}/Data/Visitor/
|
||||
${P5SITE}/Data/Visitor.pm
|
||||
${P5SITE}/Data/Visitor/Callback.pm
|
||||
@man man/man3p/Data::Visitor.3p
|
||||
@man man/man3p/Data::Visitor::Callback.3p
|
Loading…
Add table
Add a link
Reference in a new issue