SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,24 @@
COMMENT= validate user input from a constraint object
MODULES= cpan
PKG_ARCH= *
DISTNAME= Data-FormValidator-4.88
CATEGORIES= devel
REVISION= 0
# perl
PERMIT_PACKAGE= Yes
RUN_DEPENDS= graphics/p5-Image-Size \
devel/p5-Date-Calc \
misc/p5-File-MMagic \
mail/p5-Email-Valid \
mail/p5-MIME-Types \
textproc/p5-Regexp-Common
TEST_DEPENDS= textproc/p5-Template \
www/p5-CGI \
www/p5-CGI-Simple
MAKE_ENV += TEST_POD=Yes
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (Data-FormValidator-4.88.tar.gz) = waU5+RySy82KjYNZfsmnZD/NjM9alOFTgsN2UokXAGY=
SIZE (Data-FormValidator-4.88.tar.gz) = 99850

View file

@ -0,0 +1,29 @@
- Prevent the installation of README.Pod in an inappropriate place.
- Don't install Data::Readme.3p, the content is similar to
Data::FormValidator.3p.
Taken from:
https://metacpan.org/source/BDFOY/Test-File-1.43//Makefile.PL
Upstream bug report:
https://rt.cpan.org/Public/Bug/Display.html?id=128187
Index: Makefile.PL
--- Makefile.PL.orig
+++ Makefile.PL
@@ -37,3 +37,18 @@ WriteMakefile(
: ()
),
);
+
+
+BEGIN {
+ use ExtUtils::MM_Unix;
+ package ExtUtils::MM_Unix;
+
+ my $original = \&ExtUtils::MM_Unix::init_dirscan;
+ no warnings 'redefine';
+
+ *init_dirscan = sub {
+ &$original;
+ delete $_[0]{PM}{'README.pod'};
+ $_[0];
+ };
+}

View file

@ -0,0 +1,9 @@
Data::FormValidator's main aim is to make input validation expressible
in a simple format.
Data::FormValidator lets you define profiles which declare the
required and optional fields and any constraints they might have.
The results are provided as an object which makes it easy to handle
missing and invalid results, return error messages about which
constraints failed, or process the resulting valid data.

View file

@ -0,0 +1,17 @@
${P5SITE}/Data/
${P5SITE}/Data/FormValidator/
${P5SITE}/Data/FormValidator.pm
${P5SITE}/Data/FormValidator/Constraints/
${P5SITE}/Data/FormValidator/Constraints.pm
${P5SITE}/Data/FormValidator/Constraints/Dates.pm
${P5SITE}/Data/FormValidator/Constraints/Upload.pm
${P5SITE}/Data/FormValidator/ConstraintsFactory.pm
${P5SITE}/Data/FormValidator/Filters.pm
${P5SITE}/Data/FormValidator/Results.pm
@man man/man3p/Data::FormValidator.3p
@man man/man3p/Data::FormValidator::Constraints.3p
@man man/man3p/Data::FormValidator::Constraints::Dates.3p
@man man/man3p/Data::FormValidator::Constraints::Upload.3p
@man man/man3p/Data::FormValidator::ConstraintsFactory.3p
@man man/man3p/Data::FormValidator::Filters.3p
@man man/man3p/Data::FormValidator::Results.3p