SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,25 @@
PKG_ARCH= *
COMMENT= C headers and binutils linker scripts for ${TARGET}
TOOL= msp430mcu
TOOL_V= ${LTS_V}
REVISION= 0
# msp430mcu-20120406-sf3522088.patch doesn't apply to us, since ${BINDIR}
# is already created by mtree.
CONFIGURE_STYLE=# This space intentionally left blank
RUN_DEPENDS= devel/msp430/libc>=20120224
NO_BUILD= Yes
do-install:
cd ${WRKSRC} && \
MSP430MCU_ROOT=${WRKSRC} TRUEPREFIX=${TRUEPREFIX} \
/bin/sh scripts/install.sh ${PREFIX}
chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/msp430/
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (msp430/msp430mcu-20120406.tar.bz2) = BjcBTo5Ql0bD9t+OHWW3hncNFis6C4ZUi992rDECyW4=
SIZE (msp430/msp430mcu-20120406.tar.bz2) = 4191854

View file

@ -0,0 +1,19 @@
--- scripts/install.sh.orig Fri Apr 6 15:19:43 2012
+++ scripts/install.sh Sun Apr 15 19:37:11 2012
@@ -33,10 +33,15 @@ install -p -m 0644 ${ANALYSIS}/msp430mcu.spec ${LIBPAT
cp -pr ${ANALYSIS}/ldscripts ${LIBPATH}
chmod -R og+rX ${LIBPATH}/ldscripts
+# After doing fancy pansy stuff with the previously set variables, correct
+# it so that it doesn't contain the build directory anymore.
+INCPATH=${TRUEPREFIX}/msp430/include
+LIBPATH=${TRUEPREFIX}/msp430/lib
+
# Install utility that tells where everything got installed
cat bin/msp430mcu-config.in \
| sed \
- -e 's!@PREFIX@!'"${PREFIX}"'!g' \
+ -e 's!@PREFIX@!'"${TRUEPREFIX}"'!g' \
-e 's!@SCRIPTPATH@!'"${LIBPATH}/ldscripts"'!g' \
-e 's!@INCPATH@!'"${INCPATH}"'!g' \
-e 's!@VERSION@!'"${VERSION}"'!g' \

View file

@ -0,0 +1,2 @@
msp430mcu provides C headers and binutils linker scripts for each of the
over 300 microcontrollers in the MSP430 family.

File diff suppressed because it is too large Load diff