SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

24
devel/msp430/gdb/Makefile Normal file
View file

@ -0,0 +1,24 @@
TOOL= gdb
TOOL_V= 7.2a
LTS_V= 20111205
REVISION= 3
GNU_TOOL= Yes
MASTER_SITES= ${MASTER_SITE_GNU:=gdb/}
RUN_DEPENDS= devel/msp430/binutils>=2.21.1a \
devel/msp430/gcc>=4.6.3
BUILD_DEPENDS= ${RUN_DEPENDS}
WANTLIB= c expat m curses z
CONFIGURE_ARGS+= --disable-werror
WRKDIST= ${WRKDIR}/${DISTNAME:S/a$//}
# XXX: Tries to install the xml syscall files?
SEPARATE_BUILD= No
.include <bsd.port.mk>

View file

@ -0,0 +1,4 @@
SHA256 (msp430/gdb-7.2a.tar.bz2) = PCTd4zLjO/4tWYDHJtdiJOv4MEJ4ESoHv3AfjSFF2bw=
SHA256 (msp430/msp430-gdb-7.2a-20111205.patch) = twtU314A0ko6W3RFRah85la9yIVGCBxv+r77xNbEKVY=
SIZE (msp430/gdb-7.2a.tar.bz2) = 18943981
SIZE (msp430/msp430-gdb-7.2a-20111205.patch) = 382048

View file

@ -0,0 +1,11 @@
--- bfd/doc/Makefile.in.orig Tue Nov 30 11:51:27 2010
+++ bfd/doc/Makefile.in Tue Nov 30 11:51:33 2010
@@ -68,7 +68,7 @@ CONFIG_CLEAN_VPATH_FILES =
depcomp =
am__depfiles_maybe =
SOURCES =
-INFO_DEPS = bfd.info
+INFO_DEPS =
TEXINFO_TEX = $(top_srcdir)/../texinfo/texinfo.tex
am__TEXINFO_TEX_DIR = $(top_srcdir)/../texinfo
DVIS = bfd.dvi

View file

@ -0,0 +1,11 @@
--- etc/Makefile.in.orig Tue Nov 30 11:51:06 2010
+++ etc/Makefile.in Tue Nov 30 11:51:15 2010
@@ -64,7 +64,7 @@ PDFFILES = standards.pdf configure.pdf
HTMLFILES = standards.html configure.html
all: info
-install: install-info
+install:
uninstall:

View file

@ -0,0 +1,13 @@
Don't install the xml syscall files which only contain Linux' syscalls.
--- gdb/Makefile.in.orig Thu Sep 1 19:30:12 2011
+++ gdb/Makefile.in Thu Sep 1 19:30:12 2011
@@ -1004,7 +1004,7 @@ install: all install-only
# The "install-only" target also installs the syscalls' XML files in
# the system.
-install-only: $(CONFIG_INSTALL) xml-syscall-install
+install-only: $(CONFIG_INSTALL)
transformed_name=`t='$(program_transform_name)'; \
echo gdb | sed -e "$$t"` ; \
if test "x$$transformed_name" = x; then \

View file

@ -0,0 +1,11 @@
--- gdb/doc/Makefile.in.orig Tue Nov 30 11:50:40 2010
+++ gdb/doc/Makefile.in Tue Nov 30 11:50:51 2010
@@ -71,7 +71,7 @@ SET_TEXINPUTS = \
TEXINPUTS=${TEXIDIR}:.:$(srcdir):$(READLINE_DIR):$(GDBMI_DIR):$$TEXINPUTS
# Files which should be generated via 'info' and installed by 'install-info'
-INFO_DEPS = gdb.info gdbint.info stabs.info annotate.info
+INFO_DEPS =
# Files which should be generated via 'pdf' and installed by 'install-pdf'
PDFFILES = gdb.pdf gdbint.pdf stabs.pdf refcard.pdf annotate.pdf

View file

@ -0,0 +1,11 @@
--- libiberty/Makefile.in.orig Tue Nov 30 11:50:04 2010
+++ libiberty/Makefile.in Tue Nov 30 11:50:19 2010
@@ -321,7 +321,7 @@ libiberty.html : $(srcdir)/libiberty.texi $(TEXISRC)
@MAINT@ echo stamp > stamp-functions
INSTALL_DEST = @INSTALL_DEST@
-install: install_to_$(INSTALL_DEST) install-subdir
+install:
# This is tricky. Even though CC in the Makefile contains
# multilib-specific flags, it's overridden by FLAGS_TO_PASS from the

View file

@ -0,0 +1,13 @@
check-expandargv randomly succeeds or fails w/o a reason.
--- libiberty/testsuite/Makefile.in.orig Tue Nov 30 12:51:50 2010
+++ libiberty/testsuite/Makefile.in Tue Nov 30 12:52:01 2010
@@ -45,7 +45,7 @@ all:
# CHECK is set to "really_check" or the empty string by configure.
check: @CHECK@
-really-check: check-cplus-dem check-pexecute check-expandargv
+really-check: check-cplus-dem check-pexecute
# Run some tests of the demangler.
check-cplus-dem: test-demangle $(srcdir)/demangle-expected

View file

@ -0,0 +1,25 @@
Index: sim/msp430/interp.c
--- sim/msp430/interp.c.orig
+++ sim/msp430/interp.c
@@ -1880,18 +1880,18 @@ get_stop_addr (struct bfd *abfd)
storage_needed = bfd_get_symtab_upper_bound (abfd);
if (storage_needed < 0)
- return;
+ return 0;
if (storage_needed == 0)
{
- return;
+ return 0;
}
symbol_table = (asymbol **) xmalloc (storage_needed);
number_of_symbols = bfd_canonicalize_symtab (abfd, symbol_table);
if (number_of_symbols < 0)
- return;
+ return 0;
for (i = 0; i < number_of_symbols; i++)
{

View file

@ -0,0 +1,4 @@
This is the GNU debugger, configured for the msp430 target.
For more information, type "help" from within GDB, or consult the
GDB manual (available as on-line info or a printed manual).

View file

@ -0,0 +1,8 @@
@conflict ti-msp430gcc-*
@bin bin/msp430-gdb
@bin bin/msp430-gdbtui
@bin bin/msp430-run
lib/libmsp430-sim.a
@man man/man1/msp430-gdb.1
@man man/man1/msp430-gdbtui.1
@man man/man1/msp430-run.1