SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

31
devel/mcs/Makefile Normal file
View file

@ -0,0 +1,31 @@
COMMENT = abstract the storage of configuration settings
DISTNAME = libmcs-0.7.2
PKGNAME = ${DISTNAME:S/lib//}
REVISION = 2
SHARED_LIBS = mcs 1.0
CATEGORIES = devel
HOMEPAGE = https://github.com/atheme/libmcs
# BSD
PERMIT_PACKAGE = Yes
WANTLIB = c mowgli
MASTER_SITES = http://distfiles.atheme.org/
EXTRACT_SUFX = .tgz
LIB_DEPENDS = devel/mowgli
MAKE_ENV = LIBmcs_VERSION=${LIBmcs_VERSION}
CONFIGURE_STYLE = gnu
CONFIGURE_ARGS = --disable-gconf \
--disable-kconfig
NO_TEST = Yes
.include <bsd.port.mk>

2
devel/mcs/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (libmcs-0.7.2.tgz) = mJ+NxFmP+rL2pWSLpA8S0uLDkrfsbmbu7xlFkVZeYNk=
SIZE (libmcs-0.7.2.tgz) = 112987

View file

@ -0,0 +1,11 @@
--- buildsys.mk.in.orig Wed Jul 14 09:18:59 2010
+++ buildsys.mk.in Sat Dec 4 17:38:36 2010
@@ -90,7 +90,7 @@ OBJS9 = ${OBJS8:.xpm=.o}
OBJS10 = ${OBJS9:.S=.o}
OBJS += ${OBJS10:.po=.gmo}
-.SILENT:
+#.SILENT:
.SUFFIXES:
.SUFFIXES: .beam .c .cc .cxx .d .dep .erl .gmo .m .mm .o .po .py .pyc .xpm .S
.PHONY: all subdirs pre-depend depend install install-extra uninstall uninstall-extra clean distclean

View file

@ -0,0 +1,14 @@
--- configure.orig Wed Jul 14 09:19:00 2010
+++ configure Sat Dec 4 17:17:04 2010
@@ -3321,9 +3321,9 @@ $as_echo "Solaris" >&6; }
$as_echo "OpenBSD" >&6; }
LIB_CPPFLAGS='-DPIC'
LIB_CFLAGS='-fPIC'
- LIB_LDFLAGS='-shared -fPIC'
+ LIB_LDFLAGS='-shared -fPIC -Wl,-soname=${LIB}'
LIB_PREFIX='lib'
- LIB_SUFFIX='.so.${LIB_MAJOR}.${LIB_MINOR}'
+ LIB_SUFFIX='.so'
LDFLAGS_RPATH='-Wl,-rpath,${libdir}'
PLUGIN_CPPFLAGS='-DPIC'
PLUGIN_CFLAGS='-fPIC'

View file

@ -0,0 +1,8 @@
--- src/libmcs/Makefile.orig Sun Jan 4 09:27:02 2009
+++ src/libmcs/Makefile Sun Jan 4 09:27:06 2009
@@ -1,4 +1,4 @@
-LIB = ${LIB_PREFIX}mcs${LIB_SUFFIX}
+LIB = ${LIB_PREFIX}mcs${LIB_SUFFIX}.${LIBmcs_VERSION}
LIB_MAJOR = 1
LIB_MINOR = 0

10
devel/mcs/pkg/DESCR Normal file
View file

@ -0,0 +1,10 @@
mcs is a library and set of userland tools which abstract the
storage of configuration settings away from userland applications.
It is hoped that by using mcs, that the applications which use it
will generally have a more congruent feeling in regards to settings.
There have been other projects like this before (such as GConf), but
unlike those projects, mcs strictly handles abstraction. It does not
impose any specific data storage requirement, nor is it tied to any
desktop environment or software suite.

11
devel/mcs/pkg/PLIST Normal file
View file

@ -0,0 +1,11 @@
@bin bin/mcs-getconfval
@bin bin/mcs-info
@bin bin/mcs-query-backends
@bin bin/mcs-setconfval
@bin bin/mcs-walk-config
include/libmcs/
include/libmcs/mcs.h
@lib lib/libmcs.so.${LIBmcs_VERSION}
lib/mcs/
lib/mcs/keyfile.so
lib/pkgconfig/libmcs.pc