SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
34
devel/luaalarm/Makefile
Normal file
34
devel/luaalarm/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
COMMENT= alarm library for the lua language
|
||||
|
||||
DISTNAME= lalarm
|
||||
DATE= 20061011
|
||||
PKGNAME= luaalarm-${DATE}
|
||||
REVISION = 3
|
||||
# don't use PKGNAME
|
||||
DIST_SUBDIR= luaalarm-${DATE}
|
||||
WRKDIST= ${WRKDIR}/alarm
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTER_SITES= ${HOMEPAGE}5.0/
|
||||
HOMEPAGE= http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/
|
||||
|
||||
# PD
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
MODULES= lang/lua
|
||||
|
||||
FLAVORS= lua52 lua53
|
||||
FLAVOR?=
|
||||
|
||||
pre-configure:
|
||||
${SUBST_CMD} ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${MODLUA_LIBDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/alarm.so ${MODLUA_LIBDIR}
|
||||
|
||||
do-test:
|
||||
rm ${WRKDIST}/alarm.lua
|
||||
cd ${WRKDIST} && ${MODLUA_BIN} test.lua
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/luaalarm/distinfo
Normal file
2
devel/luaalarm/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (luaalarm-20061011/lalarm.tar.gz) = DHeX0TXGqxA+RkU3VzCQxcRnNOMfrnJomhs/j5t164o=
|
||||
SIZE (luaalarm-20061011/lalarm.tar.gz) = 2013
|
31
devel/luaalarm/patches/patch-Makefile
Normal file
31
devel/luaalarm/patches/patch-Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- Makefile.orig Wed Oct 11 16:13:03 2006
|
||||
+++ Makefile Sun Jul 8 19:12:08 2012
|
||||
@@ -1,23 +1,23 @@
|
||||
# makefile for alarm library for Lua
|
||||
|
||||
# change these to reflect your Lua installation
|
||||
-LUA= /tmp/lhf/lua-5.0
|
||||
-LUAINC= $(LUA)/include
|
||||
+LUA= $(LOCALBASE)
|
||||
+LUAINC= ${MODLUA_INCL_DIR}
|
||||
LUALIB= $(LUA)/lib
|
||||
LUABIN= $(LUA)/bin
|
||||
|
||||
# no need to change anything below here
|
||||
-CFLAGS= $(INCS) $(WARN) -O2 $G
|
||||
+CFLAGS+= $(INCS) -fPIC -DPIC $G
|
||||
WARN= -pedantic -Wall
|
||||
INCS= -I$(LUAINC)
|
||||
|
||||
MYNAME= alarm
|
||||
MYLIB= l$(MYNAME)
|
||||
-T= $(MYLIB).so
|
||||
+T= alarm.so
|
||||
OBJS= $(MYLIB).o
|
||||
TEST= test.lua
|
||||
|
||||
-all: test
|
||||
+all: so
|
||||
|
||||
test: $T
|
||||
$(LUABIN)/lua -l$(MYNAME) $(TEST)
|
8
devel/luaalarm/patches/patch-test_lua
Normal file
8
devel/luaalarm/patches/patch-test_lua
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- test.lua.orig Mon Jun 4 21:03:19 2007
|
||||
+++ test.lua Mon Jun 4 21:03:26 2007
|
||||
@@ -1,4 +1,5 @@
|
||||
-- test alarm
|
||||
+require("alarm")
|
||||
|
||||
function myalarm()
|
||||
print("in alarm!",os.date"%T",a,math.floor(100*a/N).."%")
|
1
devel/luaalarm/pkg/DESCR
Normal file
1
devel/luaalarm/pkg/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
luaalarm is a Lua library that permits the handling and use of SIGALRM.
|
1
devel/luaalarm/pkg/PLIST
Normal file
1
devel/luaalarm/pkg/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
lib/lua/${MODLUA_VERSION}/alarm.so
|
Loading…
Add table
Add a link
Reference in a new issue