SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
23
devel/libvirt-glib/patches/patch-examples_meson_build
Normal file
23
devel/libvirt-glib/patches/patch-examples_meson_build
Normal file
|
@ -0,0 +1,23 @@
|
|||
From 9a34c4ea55e0246c34896e48b8ecd637bc559ac7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 27 Sep 2021 14:58:17 +0100
|
||||
Subject: [PATCH] build: don't set glib version constraints for g-ir-scanner
|
||||
|
||||
Index: examples/meson.build
|
||||
--- examples/meson.build.orig
|
||||
+++ examples/meson.build
|
||||
@@ -1,5 +1,6 @@
|
||||
executable(
|
||||
'event-test',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['event-test.c'],
|
||||
dependencies: libvirt_glib_dep,
|
||||
include_directories: top_include_dir,
|
||||
@@ -7,6 +8,7 @@ executable(
|
||||
|
||||
executable(
|
||||
'conn-test',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['conn-test.c'],
|
||||
dependencies: [libvirt_glib_dep, libvirt_gconfig_dep, libvirt_gobject_dep],
|
||||
include_directories: top_include_dir,
|
|
@ -0,0 +1,17 @@
|
|||
From e0bfc34682744a74b850fa217e9c206a9eb80612 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 23 Nov 2022 16:47:52 +0100
|
||||
Subject: [PATCH] libvirt-gconfig-domain-capabilities-os.c: fix pointer-sign issue
|
||||
|
||||
Index: libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c
|
||||
--- libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c.orig
|
||||
+++ libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c
|
||||
@@ -67,7 +67,7 @@ static gboolean search_firmwares(xmlNodePtr node, gpoi
|
||||
{
|
||||
const gchar *content;
|
||||
|
||||
- if (!g_str_equal(node->name, "enum"))
|
||||
+ if (!g_str_equal((const gchar *)node->name, "enum"))
|
||||
return TRUE;
|
||||
|
||||
content = gvir_config_xml_get_attribute_content(node, "name");
|
|
@ -0,0 +1,31 @@
|
|||
From 9a34c4ea55e0246c34896e48b8ecd637bc559ac7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 27 Sep 2021 14:58:17 +0100
|
||||
Subject: [PATCH] build: don't set glib version constraints for g-ir-scanner
|
||||
|
||||
Index: libvirt-gconfig/tests/meson.build
|
||||
--- libvirt-gconfig/tests/meson.build.orig
|
||||
+++ libvirt-gconfig/tests/meson.build
|
||||
@@ -1,5 +1,6 @@
|
||||
test_domain_create = executable(
|
||||
'test-domain-create',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['test-domain-create.c'],
|
||||
include_directories: top_include_dir,
|
||||
dependencies: [libvirt_gconfig_dep]
|
||||
@@ -7,6 +8,7 @@ test_domain_create = executable(
|
||||
|
||||
test_domain_parse = executable(
|
||||
'test-domain-parse',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['test-domain-parse.c'],
|
||||
include_directories: top_include_dir,
|
||||
dependencies: [libvirt_gconfig_dep]
|
||||
@@ -14,6 +16,7 @@ test_domain_parse = executable(
|
||||
|
||||
test_capabilities_parse = executable(
|
||||
'test-capabilities-parse',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['test-capabilities-parse.c'],
|
||||
include_directories: top_include_dir,
|
||||
dependencies: [libvirt_gconfig_dep]
|
39
devel/libvirt-glib/patches/patch-meson_build
Normal file
39
devel/libvirt-glib/patches/patch-meson_build
Normal file
|
@ -0,0 +1,39 @@
|
|||
From 9a34c4ea55e0246c34896e48b8ecd637bc559ac7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 27 Sep 2021 14:58:17 +0100
|
||||
Subject: [PATCH] build: don't set glib version constraints for g-ir-scanner
|
||||
|
||||
Should match b_lundef in meson(1).
|
||||
|
||||
Index: meson.build
|
||||
--- meson.build.orig
|
||||
+++ meson.build
|
||||
@@ -50,9 +50,6 @@ libvirt_dep = dependency('libvirt', version: '>=' + li
|
||||
libxml_min_version='>=2.9.1'
|
||||
libxml_dep = dependency('libxml-2.0', version: libxml_min_version)
|
||||
|
||||
-add_global_arguments('-DGLIB_VERSION_MIN_REQUIRED=@0@'.format(glib_min_version_symbol), language: 'c')
|
||||
-add_global_arguments('-DGLIB_VERSION_MAX_ALLOWED=@0@'.format(glib_min_version_symbol), language: 'c')
|
||||
-
|
||||
prefix = get_option('prefix')
|
||||
localedir = join_paths(prefix, get_option('localedir'))
|
||||
datadir = join_paths(prefix, get_option('datadir'))
|
||||
@@ -91,9 +88,6 @@ else
|
||||
endif
|
||||
|
||||
common_link_args = []
|
||||
-if meson.get_compiler('c').has_link_argument('-Wl,--no-undefined')
|
||||
- common_link_args += ['-Wl,--no-undefined']
|
||||
-endif
|
||||
|
||||
|
||||
build_tests = not get_option('tests').disabled()
|
||||
@@ -518,6 +512,8 @@ common_cflags = [
|
||||
'-DLOCALEDIR="@0@"'.format(localedir),
|
||||
'-DDATADIR="@0@"'.format(datadir),
|
||||
'-DLIBVIRT_GLIB_BUILD',
|
||||
+ '-DGLIB_VERSION_MIN_REQUIRED=@0@'.format(glib_min_version_symbol),
|
||||
+ '-DGLIB_VERSION_MAX_ALLOWED=@0@'.format(glib_min_version_symbol),
|
||||
]
|
||||
|
||||
gnome = import('gnome')
|
24
devel/libvirt-glib/patches/patch-tests_meson_build
Normal file
24
devel/libvirt-glib/patches/patch-tests_meson_build
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 9a34c4ea55e0246c34896e48b8ecd637bc559ac7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
||||
Date: Mon, 27 Sep 2021 14:58:17 +0100
|
||||
Subject: [PATCH] build: don't set glib version constraints for g-ir-scanner
|
||||
|
||||
Index: tests/meson.build
|
||||
--- tests/meson.build.orig
|
||||
+++ tests/meson.build
|
||||
@@ -4,6 +4,7 @@ testenv.append('G_TEST_BUILDDIR', meson.current_build_
|
||||
|
||||
test_gconfig = executable(
|
||||
'test-gconfig',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['test-gconfig.c'],
|
||||
include_directories: top_include_dir,
|
||||
dependencies: [libvirt_gconfig_dep]
|
||||
@@ -12,6 +13,7 @@ test('gconfig', test_gconfig, env: testenv)
|
||||
|
||||
test_events = executable(
|
||||
'test-events',
|
||||
+ c_args: common_cflags,
|
||||
sources: ['test-events.c'],
|
||||
include_directories: top_include_dir,
|
||||
dependencies: [libvirt_glib_dep]
|
Loading…
Add table
Add a link
Reference in a new issue