SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

20
devel/libsmb2/Makefile Normal file
View file

@ -0,0 +1,20 @@
COMMENT= userspace client library for accessing SMB2/SMB3 shares
GH_ACCOUNT= sahlberg
GH_PROJECT= libsmb2
GH_TAGNAME= v4.0.0
CATEGORIES= devel
SHARED_LIBS= smb2 1.0
MAINTAINER= Brad Smith <brad@comstyle.com>
# LGPLv2.1+
PERMIT_PACKAGE= Yes
MODULES= devel/cmake
NO_TEST= Yes
.include <bsd.port.mk>

2
devel/libsmb2/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (libsmb2-4.0.0.tar.gz) = tNGxO8B63Gg3mnL3I7kDKpUK/WL+1/KqPlfzQhQG2hE=
SIZE (libsmb2-4.0.0.tar.gz) = 171678

View file

@ -0,0 +1,20 @@
Fix netinet/tcp.h header check to include prerequisite headers.
Index: cmake/ConfigureChecks.cmake
--- cmake/ConfigureChecks.cmake.orig
+++ cmake/ConfigureChecks.cmake
@@ -1,4 +1,5 @@
include(CheckIncludeFile)
+include(CheckIncludeFiles)
check_include_file("arpa/inet.h" HAVE_ARPA_INET_H)
check_include_file("dlfcn.h" HAVE_DLFCN_H)
check_include_file("gssapi/gssapi.h" HAVE_GSSAPI_GSSAPI_H)
@@ -6,7 +7,7 @@ check_include_file("inttypes.h" HAVE_INTTYPES_H)
check_include_file("memory.h" HAVE_MEMORY_H)
check_include_file("netdb.h" HAVE_NETDB_H)
check_include_file("netinet/in.h" HAVE_NETINET_IN_H)
-check_include_file("netinet/tcp.h" HAVE_NETINET_TCP_H)
+check_include_files("sys/types.h;netinet/tcp.h" HAVE_NETINET_TCP_H)
check_include_file("net/if.h" HAVE_NET_IF_H)
check_include_file("poll.h" HAVE_POLL_H)
check_include_file("stdint.h" HAVE_STDINT_H)

View file

@ -0,0 +1,12 @@
Index: lib/errors.c
--- lib/errors.c.orig
+++ lib/errors.c
@@ -1108,7 +1108,7 @@ int nterror_to_errno(uint32_t status) {
case SMB2_STATUS_FILE_DELETED:
return EPERM;
case SMB2_STATUS_NO_MORE_FILES:
- return ENODATA;
+ return ENOATTR;
case SMB2_STATUS_LOGON_FAILURE:
return ECONNREFUSED;
case SMB2_STATUS_NOT_A_DIRECTORY:

3
devel/libsmb2/pkg/DESCR Normal file
View file

@ -0,0 +1,3 @@
Libsmb2 is a userspace client library for accessing SMB2/SMB3 shares on
a network. It is high performance and fully async. It supports both
zero-copy for SMB READ/WRITE commands as well as compounded commands.

14
devel/libsmb2/pkg/PLIST Normal file
View file

@ -0,0 +1,14 @@
include/smb2/
include/smb2/libsmb2-dcerpc-lsa.h
include/smb2/libsmb2-dcerpc-srvsvc.h
include/smb2/libsmb2-dcerpc.h
include/smb2/libsmb2-raw.h
include/smb2/libsmb2.h
include/smb2/smb2-errors.h
include/smb2/smb2.h
lib/cmake/
lib/cmake/libsmb2/
lib/cmake/libsmb2/FindSMB2.cmake
lib/cmake/libsmb2/libsmb2-config-version.cmake
@lib lib/libsmb2.so.${LIBsmb2_VERSION}
lib/pkgconfig/libsmb2.pc