SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
23
devel/libsigsegv/Makefile
Normal file
23
devel/libsigsegv/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
COMMENT = library for handling page faults in user mode
|
||||
|
||||
DISTNAME = libsigsegv-2.12
|
||||
SHARED_LIBS = sigsegv 1.0
|
||||
CATEGORIES = devel
|
||||
|
||||
HOMEPAGE = https://www.gnu.org/software/libsigsegv/
|
||||
|
||||
# GPLv2
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
MASTER_SITES = ${MASTER_SITE_GNU:=libsigsegv/}
|
||||
|
||||
SEPARATE_BUILD = Yes
|
||||
|
||||
CONFIGURE_STYLE = gnu
|
||||
# We know these values, so don't run the configure tests for them which may
|
||||
# take hours to complete on certain OpenBSD platforms, such as mips64.
|
||||
CONFIGURE_ENV += sv_cv_fault_linux_i386=no \
|
||||
sv_cv_fault_linux_i386_old=no \
|
||||
sv_cv_fault_linux_m68k=no
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/libsigsegv/distinfo
Normal file
2
devel/libsigsegv/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (libsigsegv-2.12.tar.gz) = OuGvNZ7rqk/8WJahruNWjAUsmYeTFqGrV/j+F4nDkLY=
|
||||
SIZE (libsigsegv-2.12.tar.gz) = 451408
|
22
devel/libsigsegv/patches/patch-src_fault-openbsd-powerpc_h
Normal file
22
devel/libsigsegv/patches/patch-src_fault-openbsd-powerpc_h
Normal file
|
@ -0,0 +1,22 @@
|
|||
https://savannah.gnu.org/bugs/?58829
|
||||
|
||||
Index: src/fault-openbsd-powerpc.h
|
||||
--- src/fault-openbsd-powerpc.h.orig
|
||||
+++ src/fault-openbsd-powerpc.h
|
||||
@@ -17,7 +17,14 @@
|
||||
|
||||
#include "fault-openbsd.h"
|
||||
|
||||
-/* See the definition of 'struct sigcontext' and 'struct trapframe' in
|
||||
- openbsd-src/sys/arch/powerpc/include/signal.h. */
|
||||
+/* For 32-bit PowerPC, see the definition of 'struct sigcontext' and
|
||||
+ * 'struct trapframe' in openbsd-src/sys/arch/powerpc/include/signal.h.
|
||||
+ * For 64-bit PowerPC only 'struct sigcontext' is defined in
|
||||
+ * openbsd-src/sys/arch/power64/include/signal.h.
|
||||
+ */
|
||||
|
||||
+#ifdef __powerpc64__
|
||||
+#define SIGSEGV_FAULT_STACKPOINTER scp->sc_sp
|
||||
+#else
|
||||
#define SIGSEGV_FAULT_STACKPOINTER scp->sc_frame.fixreg[1]
|
||||
+#endif
|
10
devel/libsigsegv/pkg/DESCR
Normal file
10
devel/libsigsegv/pkg/DESCR
Normal file
|
@ -0,0 +1,10 @@
|
|||
This is a library for handling page faults in user mode. A page fault
|
||||
occurs when a program tries to access to a region of memory that is
|
||||
currently not available. Catching and handling a page fault is a useful
|
||||
technique for implementing:
|
||||
|
||||
* pageable virtual memory,
|
||||
* memory-mapped access to persistent databases,
|
||||
* generational garbage collectors,
|
||||
* stack overflow handlers,
|
||||
* distributed shared memory,
|
4
devel/libsigsegv/pkg/PLIST
Normal file
4
devel/libsigsegv/pkg/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
include/sigsegv.h
|
||||
lib/libsigsegv.a
|
||||
lib/libsigsegv.la
|
||||
@lib lib/libsigsegv.so.${LIBsigsegv_VERSION}
|
Loading…
Add table
Add a link
Reference in a new issue