SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

22
devel/liboop/Makefile Normal file
View file

@ -0,0 +1,22 @@
COMMENT= low-level event loop management library
DISTNAME= liboop-1.0
REVISION = 3
SHARED_LIBS= oop 4.1
CATEGORIES= devel
HOMEPAGE= http://liboop.ofb.net/
# LGPL
PERMIT_PACKAGE= Yes
MASTER_SITES= https://distfiles.sigtrap.nl/
CONFIGURE_STYLE= gnu
CONFIGURE_ARGS+= --without-adns \
--without-glib \
--without-libwww \
--without-readline \
--without-tcl
.include <bsd.port.mk>

2
devel/liboop/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (liboop-1.0.tar.gz) = NNg8bg8J7hXLK8MTHiGXR8O2ErtXz30lMYq5Dami2Xw=
SIZE (liboop-1.0.tar.gz) = 314103

View file

@ -0,0 +1,10 @@
--- select.c.orig Sat Nov 22 00:29:11 2008
+++ select.c Sat Nov 22 00:29:29 2008
@@ -7,6 +7,7 @@
#include "oop.h"
#include <assert.h>
+#include <string.h>
struct select_set {
fd_set rfd,wfd,xfd;

7
devel/liboop/pkg/DESCR Normal file
View file

@ -0,0 +1,7 @@
Liboop is a low-level event loop management library for POSIX-based
operating systems. It supports the development of modular, multiplexed
applications which may respond to events from several sources. It
replaces the "select() loop" and allows the registration of event
handlers for file and network I/O, timers and signals. Since processes
use these mechanisms for almost all external communication, liboop can
be used as the basis for almost any application.

12
devel/liboop/pkg/PLIST Normal file
View file

@ -0,0 +1,12 @@
include/oop-adns.h
include/oop-glib.h
include/oop-read.h
include/oop-rl.h
include/oop-tcl.h
include/oop-www.h
include/oop.h
lib/liboop.a
lib/liboop.la
@lib lib/liboop.so.${LIBoop_VERSION}
lib/pkgconfig/liboop-glib2.pc
lib/pkgconfig/liboop.pc