SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

34
devel/libnotify/Makefile Normal file
View file

@ -0,0 +1,34 @@
COMMENT= send desktop notifications to a notification daemon
GNOME_VERSION= 0.8.2
GNOME_PROJECT= libnotify
CATEGORIES= devel
SHARED_LIBS += notify 5.0 # 4.0.0
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
# LGPLv2.1
PERMIT_PACKAGE= Yes
WANTLIB += c gdk_pixbuf-2.0 gio-2.0 glib-2.0 gobject-2.0
MODULES= devel/meson \
x11/gnome
BUILD_DEPENDS= textproc/xmlto
# gtk+3 is needed to build the tests
BUILD_DEPENDS += x11/gtk+3
LIB_DEPENDS= graphics/gdk-pixbuf2
MODGNOME_TOOLS= gi-docgen gobject-introspection
# XXX "need to install docbook-xsl-ns or similar package"
# http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl
#MODGNOME_TOOLS += docbook
CONFIGURE_ARGS += -Dman=false
.include <bsd.port.mk>

2
devel/libnotify/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (libnotify-0.8.2.tar.xz) = xfTtPR+G5bEYx2QVqsuGGHPtPm8MazGBuCjPWE/FxhY=
SIZE (libnotify-0.8.2.tar.xz) = 105912

View file

@ -0,0 +1,14 @@
Comma at end of list isn't valid c++, and c++ code might use libnotify.
Index: libnotify/notification.h
--- libnotify/notification.h.orig
+++ libnotify/notification.h
@@ -97,7 +97,7 @@ typedef enum
{
NOTIFY_URGENCY_LOW,
NOTIFY_URGENCY_NORMAL,
- NOTIFY_URGENCY_CRITICAL,
+ NOTIFY_URGENCY_CRITICAL
} NotifyUrgency;

View file

@ -0,0 +1,4 @@
Library that sends desktop notifications to a notification daemon, as
defined in the Desktop Notifications spec. These notifications can be
used to inform the user about an event or display some form of
information without getting in the user's way.

107
devel/libnotify/pkg/PLIST Normal file
View file

@ -0,0 +1,107 @@
@bin bin/notify-send
include/libnotify/
include/libnotify/notification.h
include/libnotify/notify-enum-types.h
include/libnotify/notify-features.h
include/libnotify/notify.h
lib/girepository-1.0/Notify-0.7.typelib
@lib lib/libnotify.so.${LIBnotify_VERSION}
lib/pkgconfig/libnotify.pc
share/doc/libnotify/
share/doc/libnotify-0/
share/doc/libnotify-0/RedHatDisplay-Black.woff
share/doc/libnotify-0/RedHatDisplay-Black.woff2
share/doc/libnotify-0/RedHatDisplay-BlackItalic.woff
share/doc/libnotify-0/RedHatDisplay-BlackItalic.woff2
share/doc/libnotify-0/RedHatDisplay-Bold.woff
share/doc/libnotify-0/RedHatDisplay-Bold.woff2
share/doc/libnotify-0/RedHatDisplay-BoldItalic.woff
share/doc/libnotify-0/RedHatDisplay-BoldItalic.woff2
share/doc/libnotify-0/RedHatDisplay-Italic.woff
share/doc/libnotify-0/RedHatDisplay-Italic.woff2
share/doc/libnotify-0/RedHatDisplay-Medium.woff
share/doc/libnotify-0/RedHatDisplay-Medium.woff2
share/doc/libnotify-0/RedHatDisplay-MediumItalic.woff
share/doc/libnotify-0/RedHatDisplay-MediumItalic.woff2
share/doc/libnotify-0/RedHatDisplay-Regular.woff
share/doc/libnotify-0/RedHatDisplay-Regular.woff2
share/doc/libnotify-0/RedHatText-Bold.woff
share/doc/libnotify-0/RedHatText-Bold.woff2
share/doc/libnotify-0/RedHatText-BoldItalic.woff
share/doc/libnotify-0/RedHatText-BoldItalic.woff2
share/doc/libnotify-0/RedHatText-Italic.woff
share/doc/libnotify-0/RedHatText-Italic.woff2
share/doc/libnotify-0/RedHatText-Medium.woff
share/doc/libnotify-0/RedHatText-Medium.woff2
share/doc/libnotify-0/RedHatText-MediumItalic.woff
share/doc/libnotify-0/RedHatText-MediumItalic.woff2
share/doc/libnotify-0/RedHatText-Regular.woff
share/doc/libnotify-0/RedHatText-Regular.woff2
share/doc/libnotify-0/SourceCodePro-It.ttf.woff
share/doc/libnotify-0/SourceCodePro-Regular.ttf.woff
share/doc/libnotify-0/SourceCodePro-Semibold.ttf.woff
share/doc/libnotify-0/callback.ActionCallback.html
share/doc/libnotify-0/class.Notification.html
share/doc/libnotify-0/classes_hierarchy.html
share/doc/libnotify-0/const.EXPIRES_DEFAULT.html
share/doc/libnotify-0/const.EXPIRES_NEVER.html
share/doc/libnotify-0/const.VERSION_MAJOR.html
share/doc/libnotify-0/const.VERSION_MICRO.html
share/doc/libnotify-0/const.VERSION_MINOR.html
share/doc/libnotify-0/ctor.Notification.new.html
share/doc/libnotify-0/enum.ClosedReason.html
share/doc/libnotify-0/enum.Urgency.html
share/doc/libnotify-0/fonts.css
share/doc/libnotify-0/func.ACTION_CALLBACK.html
share/doc/libnotify-0/func.CHECK_VERSION.html
share/doc/libnotify-0/func.get_app_name.html
share/doc/libnotify-0/func.get_server_caps.html
share/doc/libnotify-0/func.get_server_info.html
share/doc/libnotify-0/func.init.html
share/doc/libnotify-0/func.is_initted.html
share/doc/libnotify-0/func.set_app_name.html
share/doc/libnotify-0/func.uninit.html
share/doc/libnotify-0/fzy.js
share/doc/libnotify-0/go-up-symbolic.png
share/doc/libnotify-0/index.html
share/doc/libnotify-0/index.json
share/doc/libnotify-0/libnotify-0.devhelp2
share/doc/libnotify-0/main.js
share/doc/libnotify-0/method.Notification.add_action.html
share/doc/libnotify-0/method.Notification.clear_actions.html
share/doc/libnotify-0/method.Notification.clear_hints.html
share/doc/libnotify-0/method.Notification.close.html
share/doc/libnotify-0/method.Notification.get_activation_token.html
share/doc/libnotify-0/method.Notification.get_closed_reason.html
share/doc/libnotify-0/method.Notification.set_app_name.html
share/doc/libnotify-0/method.Notification.set_category.html
share/doc/libnotify-0/method.Notification.set_hint.html
share/doc/libnotify-0/method.Notification.set_hint_byte.html
share/doc/libnotify-0/method.Notification.set_hint_byte_array.html
share/doc/libnotify-0/method.Notification.set_hint_double.html
share/doc/libnotify-0/method.Notification.set_hint_int32.html
share/doc/libnotify-0/method.Notification.set_hint_string.html
share/doc/libnotify-0/method.Notification.set_hint_uint32.html
share/doc/libnotify-0/method.Notification.set_icon_from_pixbuf.html
share/doc/libnotify-0/method.Notification.set_image_from_pixbuf.html
share/doc/libnotify-0/method.Notification.set_timeout.html
share/doc/libnotify-0/method.Notification.set_urgency.html
share/doc/libnotify-0/method.Notification.show.html
share/doc/libnotify-0/method.Notification.update.html
share/doc/libnotify-0/opensearch.xml
share/doc/libnotify-0/property.Notification.app-name.html
share/doc/libnotify-0/property.Notification.body.html
share/doc/libnotify-0/property.Notification.closed-reason.html
share/doc/libnotify-0/property.Notification.icon-name.html
share/doc/libnotify-0/property.Notification.id.html
share/doc/libnotify-0/property.Notification.summary.html
share/doc/libnotify-0/search.js
share/doc/libnotify-0/signal.Notification.closed.html
share/doc/libnotify-0/solarized-dark.css
share/doc/libnotify-0/solarized-light.css
share/doc/libnotify-0/style.css
share/doc/libnotify-0/urlmap.js
share/doc/libnotify-0/vfunc.Notification.closed.html
share/doc/libnotify/spec/
share/doc/libnotify/spec/notification-spec.html
share/gir-1.0/Notify-0.7.gir