SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
25
devel/libnfs/Makefile
Normal file
25
devel/libnfs/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
COMMENT= client library for accessing NFS
|
||||
|
||||
DISTNAME= libnfs-5.0.2
|
||||
CATEGORIES= devel net
|
||||
MASTER_SITES= https://github.com/sahlberg/libnfs/archive/
|
||||
|
||||
SHARED_LIBS= nfs 2.2
|
||||
|
||||
HOMEPAGE= https://github.com/sahlberg/libnfs
|
||||
|
||||
MAINTAINER= Brad Smith <brad@comstyle.com>
|
||||
|
||||
# LGPLv2.1+, GPLv3+ and BSD
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
WANTLIB= c
|
||||
|
||||
AUTOCONF_VERSION= 2.69
|
||||
AUTOMAKE_VERSION= 1.16
|
||||
|
||||
CONFIGURE_STYLE= autoreconf
|
||||
|
||||
WRKDIST= ${WRKDIR}/libnfs-${DISTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/libnfs/distinfo
Normal file
2
devel/libnfs/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (libnfs-5.0.2.tar.gz) = Y35WZDsZ2p+6mPBoR3iMTa0wi3IxVqZHSAQQNdzfm9M=
|
||||
SIZE (libnfs-5.0.2.tar.gz) = 281154
|
13
devel/libnfs/patches/patch-include_nfsc_libnfs_h
Normal file
13
devel/libnfs/patches/patch-include_nfsc_libnfs_h
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: include/nfsc/libnfs.h
|
||||
--- include/nfsc/libnfs.h.orig
|
||||
+++ include/nfsc/libnfs.h
|
||||
@@ -38,6 +38,9 @@
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
#endif
|
||||
+#if defined(__OpenBSD__)
|
||||
+#include <sys/time.h> /* gettimeofday */
|
||||
+#endif
|
||||
|
||||
#define LIBNFS_FEATURE_READAHEAD
|
||||
#define LIBNFS_FEATURE_PAGECACHE
|
17
devel/libnfs/pkg/DESCR
Normal file
17
devel/libnfs/pkg/DESCR
Normal file
|
@ -0,0 +1,17 @@
|
|||
LIBNFS is a client library for accessing NFS shares over a network.
|
||||
|
||||
LIBNFS offers three different APIs, for different use :
|
||||
|
||||
1, RAW : A fully async low level RPC library for NFS protocols This API is
|
||||
described in include/libnfs-raw.h it offers a fully async interface to raw XDR
|
||||
encoded blobs. This API provides very flexible and precise control of the RPC
|
||||
issued.
|
||||
|
||||
2, NFS ASYNC : A fully asynchronous library for high level vfs functions This
|
||||
API is described by the *_async() functions in include/libnfs.h. This API
|
||||
provides a fully async access to posix vfs like functions such as stat(),
|
||||
read(), ...
|
||||
|
||||
3, NFS SYNC : A synchronous library for high level vfs functions This API is
|
||||
described by the *_sync() functions in include/libnfs.h. This API provides
|
||||
access to posix vfs like functions such as stat(), read(), ...
|
22
devel/libnfs/pkg/PLIST
Normal file
22
devel/libnfs/pkg/PLIST
Normal file
|
@ -0,0 +1,22 @@
|
|||
@bin bin/nfs-cat
|
||||
@bin bin/nfs-cp
|
||||
@bin bin/nfs-ls
|
||||
@bin bin/nfs-stat
|
||||
include/nfsc/
|
||||
include/nfsc/libnfs-raw-mount.h
|
||||
include/nfsc/libnfs-raw-nfs.h
|
||||
include/nfsc/libnfs-raw-nfs4.h
|
||||
include/nfsc/libnfs-raw-nlm.h
|
||||
include/nfsc/libnfs-raw-nsm.h
|
||||
include/nfsc/libnfs-raw-portmap.h
|
||||
include/nfsc/libnfs-raw-rquota.h
|
||||
include/nfsc/libnfs-raw.h
|
||||
include/nfsc/libnfs-zdr.h
|
||||
include/nfsc/libnfs.h
|
||||
@static-lib lib/libnfs.a
|
||||
lib/libnfs.la
|
||||
@lib lib/libnfs.so.${LIBnfs_VERSION}
|
||||
lib/pkgconfig/libnfs.pc
|
||||
@man man/man1/nfs-cat.1
|
||||
@man man/man1/nfs-cp.1
|
||||
@man man/man1/nfs-ls.1
|
Loading…
Add table
Add a link
Reference in a new issue