SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
33
devel/libinotify/Makefile
Normal file
33
devel/libinotify/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
COMMENT = kevent based inotify
|
||||
|
||||
GH_ACCOUNT = libinotify-kqueue
|
||||
GH_PROJECT = libinotify-kqueue
|
||||
GH_TAGNAME = 20211018
|
||||
PKGNAME = libinotify-${GH_TAGNAME}
|
||||
|
||||
SHARED_LIBS = inotify 3.0
|
||||
|
||||
CATEGORIES = devel
|
||||
|
||||
MAINTAINER = Kirill Bychkov <kirby@openbsd.org>
|
||||
|
||||
# MIT
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
WANTLIB = pthread
|
||||
|
||||
DEBUG_PACKAGES = ${BUILD_PACKAGES}
|
||||
|
||||
SEPARATE_BUILD = Yes
|
||||
CONFIGURE_STYLE = autoreconf
|
||||
CONFIGURE_ARGS = --libdir=${PREFIX}/lib/inotify/ \
|
||||
--includedir=${PREFIX}/include/inotify/
|
||||
|
||||
AUTOCONF_VERSION = 2.69
|
||||
AUTOMAKE_VERSION = 1.14
|
||||
|
||||
TEST_TARGET = test
|
||||
|
||||
FAKE_FLAGS += pkgconfigdir=${PREFIX}/lib/pkgconfig/
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/libinotify/distinfo
Normal file
2
devel/libinotify/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (libinotify-kqueue-20211018.tar.gz) = 4KMthn87bRBSS0XRbaVWEfv4vLuE69QOxJ49S2S3o6Y=
|
||||
SIZE (libinotify-kqueue-20211018.tar.gz) = 74778
|
17
devel/libinotify/patches/patch-Makefile_am
Normal file
17
devel/libinotify/patches/patch-Makefile_am
Normal file
|
@ -0,0 +1,17 @@
|
|||
Drop -Werror
|
||||
Unbreak separate build
|
||||
|
||||
Index: Makefile.am
|
||||
--- Makefile.am.orig
|
||||
+++ Makefile.am
|
||||
@@ -59,8 +59,8 @@ endif
|
||||
|
||||
libinotify_la_SOURCES += compat/tree.h
|
||||
|
||||
-libinotify_la_CFLAGS = -I. @DEBUG_CFLAGS@ @PTHREAD_CFLAGS@ -Wall -Werror
|
||||
-libinotify_la_LDFLAGS = @PTHREAD_LIBS@ -export-symbols libinotify.sym
|
||||
+libinotify_la_CFLAGS = -I. @DEBUG_CFLAGS@ @PTHREAD_CFLAGS@ -Wall
|
||||
+libinotify_la_LDFLAGS = @PTHREAD_LIBS@ -export-symbols $(top_srcdir)/libinotify.sym
|
||||
endif
|
||||
|
||||
inotify_test_SOURCES = inotify-test.c
|
13
devel/libinotify/patches/patch-libinotify_pc_in
Normal file
13
devel/libinotify/patches/patch-libinotify_pc_in
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: libinotify.pc.in
|
||||
--- libinotify.pc.in.orig
|
||||
+++ libinotify.pc.in
|
||||
@@ -1,7 +1,7 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
-libdir=@libdir@
|
||||
-includedir=@includedir@
|
||||
+libdir=${exec_prefix}/lib/inotify
|
||||
+includedir=${prefix}/include/inotify
|
||||
|
||||
Name: @PACKAGE_NAME@
|
||||
Description: Kqueue based inotify shim library
|
6
devel/libinotify/pkg/DESCR
Normal file
6
devel/libinotify/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
This library provides inotify-compatible interface for applications
|
||||
that need to monitor changes happening in a filesystem. It can be useful
|
||||
when porting Linux applications, which often use inotify interface.
|
||||
|
||||
The IN_OPEN, IN_CLOSE_WRITE and IN_CLOSE_NOWRITE events are not yet
|
||||
implemented, so the relevant tests are known to fail.
|
16
devel/libinotify/pkg/PLIST
Normal file
16
devel/libinotify/pkg/PLIST
Normal file
|
@ -0,0 +1,16 @@
|
|||
include/inotify/
|
||||
include/inotify/sys/
|
||||
include/inotify/sys/inotify.h
|
||||
lib/inotify/
|
||||
@static-lib lib/inotify/libinotify.a
|
||||
lib/inotify/libinotify.la
|
||||
@lib lib/inotify/libinotify.so.${LIBinotify_VERSION}
|
||||
lib/pkgconfig/libinotify.pc
|
||||
@man man/man3/inotify_add_watch.3
|
||||
@man man/man3/inotify_event.3
|
||||
@man man/man3/inotify_init.3
|
||||
@man man/man3/inotify_init1.3
|
||||
@man man/man3/inotify_rm_watch.3
|
||||
@man man/man3/libinotify.3
|
||||
@man man/man3/libinotify_set_param.3
|
||||
share/doc/pkg-readmes/${PKGSTEM}
|
10
devel/libinotify/pkg/README
Normal file
10
devel/libinotify/pkg/README
Normal file
|
@ -0,0 +1,10 @@
|
|||
+-------------------------------------------------------------------------------
|
||||
| Running ${PKGSTEM} on OpenBSD
|
||||
+-------------------------------------------------------------------------------
|
||||
|
||||
libinotify uses kqueue(2) to monitor for changed files. This only works
|
||||
up to the system's "open file descriptors" limit - if software using
|
||||
libinotify needs to handle large directories, the kern.maxfiles
|
||||
sysctl(8) should be increased by adding an entry in sysctl.conf(5) and
|
||||
the user's login(1) class modified accordingly by bumping the "cur" and
|
||||
"max" "openfiles" limit in login.conf(5).
|
Loading…
Add table
Add a link
Reference in a new issue