SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
18
devel/http-parser/Makefile
Normal file
18
devel/http-parser/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
COMMENT = parser for HTTP messages focused on performance
|
||||
GH_ACCOUNT = nodejs
|
||||
GH_PROJECT = http-parser
|
||||
GH_TAGNAME = v2.9.3
|
||||
CATEGORIES = devel
|
||||
|
||||
SHARED_LIBS = http_parser 0.0 #2.9
|
||||
|
||||
# MIT
|
||||
PERMIT_PACKAGE =yes
|
||||
|
||||
MAKE_ENV = SONAME=libhttp_parser.so.${LIBhttp_parser_VERSION} \
|
||||
LIBNAME=libhttp_parser.so.${LIBhttp_parser_VERSION}
|
||||
|
||||
USE_GMAKE = yes
|
||||
ALL_TARGET = library
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/http-parser/distinfo
Normal file
2
devel/http-parser/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (http-parser-2.9.3.tar.gz) = j6Crh3D9hCWptDH9v5FiPE16nNuEK5M5KJvSsLAbDT0=
|
||||
SIZE (http-parser-2.9.3.tar.gz) = 51973
|
27
devel/http-parser/patches/patch-Makefile
Normal file
27
devel/http-parser/patches/patch-Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
Index: Makefile
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
@@ -53,8 +53,8 @@ CPPFLAGS_FAST += $(CPPFLAGS_FAST_EXTRA)
|
||||
CPPFLAGS_BENCH = $(CPPFLAGS_FAST)
|
||||
|
||||
CFLAGS += -Wall -Wextra -Werror
|
||||
-CFLAGS_DEBUG = $(CFLAGS) -O0 -g $(CFLAGS_DEBUG_EXTRA)
|
||||
-CFLAGS_FAST = $(CFLAGS) -O3 $(CFLAGS_FAST_EXTRA)
|
||||
+CFLAGS_DEBUG = $(CFLAGS) -g $(CFLAGS_DEBUG_EXTRA)
|
||||
+CFLAGS_FAST = $(CFLAGS) $(CFLAGS_FAST_EXTRA)
|
||||
CFLAGS_BENCH = $(CFLAGS_FAST) -Wno-unused-parameter
|
||||
CFLAGS_LIB = $(CFLAGS_FAST) -fPIC
|
||||
|
||||
@@ -131,10 +131,8 @@ tags: http_parser.c http_parser.h test.c
|
||||
ctags $^
|
||||
|
||||
install: library
|
||||
- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
|
||||
- $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
|
||||
- ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
|
||||
- ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
|
||||
+ $(INSTALL) -D http_parser.h $(INCLUDEDIR)/http_parser.h
|
||||
+ $(INSTALL) -D $(LIBNAME) $(LIBDIR)/$(LIBNAME)
|
||||
|
||||
install-strip: library
|
||||
$(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
|
5
devel/http-parser/pkg/DESCR
Normal file
5
devel/http-parser/pkg/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
This is a parser for HTTP messages written in C. It parses both requests and
|
||||
responses. The parser is designed to be used in performance HTTP applications.
|
||||
It does not make any syscalls nor allocations, it does not buffer data, it can
|
||||
be interrupted at anytime. Depending on your architecture, it only requires
|
||||
about 40 bytes of data per message stream.
|
2
devel/http-parser/pkg/PLIST
Normal file
2
devel/http-parser/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
include/http_parser.h
|
||||
@lib lib/libhttp_parser.so.${LIBhttp_parser_VERSION}
|
Loading…
Add table
Add a link
Reference in a new issue