SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

69
devel/harfbuzz/Makefile Normal file
View file

@ -0,0 +1,69 @@
BROKEN-hppa= no atomic primitives
COMMENT-main= text shaping library
COMMENT-icu= ICU support for libharfbuzz
V= 8.1.1
DISTNAME= harfbuzz-${V}
EXTRACT_SUFX= .tar.xz
SHARED_LIBS += harfbuzz 18.5 # 0.60810.0
SHARED_LIBS += harfbuzz-subset 2.4 # 0.60810.0
SHARED_LIBS += harfbuzz-cairo 0.1 # 0.60810.0
SHARED_LIBS += harfbuzz-icu 2.1 # 0.60810.0
SHARED_LIBS += harfbuzz-gobject 1.1 # 0.60810.0
CATEGORIES= devel graphics textproc
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
# MIT
PERMIT_PACKAGE= Yes
MASTER_SITES= https://github.com/harfbuzz/harfbuzz/releases/download/${V}/
WANTLIB-main += c cairo freetype glib-2.0 gobject-2.0 graphite2 m
WANTLIB-icu += harfbuzz icuuc
MULTI_PACKAGES= -main -icu
DEBUG_PACKAGES= ${BUILD_PACKAGES}
# C++11
COMPILER= base-clang ports-gcc ports-clang
MODULES= devel/meson
BUILD_DEPENDS= devel/gobject-introspection
# XXX Program ragel found: NO found 6.9 but need: '6.10' (/usr/local/bin/ragel)
#BUILD_DEPENDS += devel/ragel
LIB_DEPENDS-main= graphics/cairo \
graphics/graphite2
LIB_DEPENDS-icu= devel/harfbuzz,-main=${V} \
textproc/icu4c
.include <bsd.port.arch.mk>
.if !${PROPERTIES:Mclang}
# needed for estdc++ in WANTLIB
LIB_DEPENDS-main += ${LIB_DEPENDS}
.endif
CONFIGURE_ARGS= -Dgraphite2=enabled
# bloat: needs gtk-doc
CONFIGURE_ARGS += -Ddocs=disabled
# bloat: requires ImageMagick, libwebp...
CONFIGURE_ARGS += -Dchafa=disabled
# XXX: infinite loop
CONFIGURE_ARGS += -Dtests=disabled
pre-configure:
${SUBST_CMD} ${WRKSRC}/src/check-symbols.py
.include <bsd.port.mk>

2
devel/harfbuzz/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (harfbuzz-8.1.1.tar.xz) = AwWtcC4RkGpfwMG6EcJwt/ZKj1OQ1naqz9cdsSnWVl8=
SIZE (harfbuzz-8.1.1.tar.xz) = 18820088

View file

@ -0,0 +1,12 @@
Index: src/check-symbols.py
--- src/check-symbols.py.orig
+++ src/check-symbols.py
@@ -23,7 +23,7 @@ tested = False
stat = 0
for soname in ['harfbuzz', 'harfbuzz-subset', 'harfbuzz-icu', 'harfbuzz-gobject', 'harfbuzz-cairo']:
- for suffix in ['so', 'dylib']:
+ for suffix in ['so.${LIBharfbuzz_VERSION}', 'dylib']:
so = os.path.join (builddir, libs, 'lib%s.%s' % (soname, suffix))
if not os.path.exists (so): continue

View file

@ -0,0 +1 @@
harfbuzz-icu provides ICU support for libharfbuzz.

View file

@ -0,0 +1 @@
HarfBuzz is an OpenType text shaping engine.

View file

@ -0,0 +1,4 @@
@conflict harfbuzz-<0.9.18
include/harfbuzz/hb-icu.h
@lib lib/libharfbuzz-icu.so.${LIBharfbuzz-icu_VERSION}
lib/pkgconfig/harfbuzz-icu.pc

View file

@ -0,0 +1,62 @@
@pkgpath devel/harfbuzz
@bin bin/hb-info
@bin bin/hb-ot-shape-closure
@bin bin/hb-shape
@bin bin/hb-subset
@bin bin/hb-view
include/harfbuzz/
include/harfbuzz/hb-aat-layout.h
include/harfbuzz/hb-aat.h
include/harfbuzz/hb-blob.h
include/harfbuzz/hb-buffer.h
include/harfbuzz/hb-cairo.h
include/harfbuzz/hb-common.h
include/harfbuzz/hb-cplusplus.hh
include/harfbuzz/hb-deprecated.h
include/harfbuzz/hb-draw.h
include/harfbuzz/hb-face.h
include/harfbuzz/hb-features.h
include/harfbuzz/hb-font.h
include/harfbuzz/hb-ft.h
include/harfbuzz/hb-glib.h
include/harfbuzz/hb-gobject-enums.h
include/harfbuzz/hb-gobject-structs.h
include/harfbuzz/hb-gobject.h
include/harfbuzz/hb-graphite2.h
include/harfbuzz/hb-map.h
include/harfbuzz/hb-ot-color.h
include/harfbuzz/hb-ot-deprecated.h
include/harfbuzz/hb-ot-font.h
include/harfbuzz/hb-ot-layout.h
include/harfbuzz/hb-ot-math.h
include/harfbuzz/hb-ot-meta.h
include/harfbuzz/hb-ot-metrics.h
include/harfbuzz/hb-ot-name.h
include/harfbuzz/hb-ot-shape.h
include/harfbuzz/hb-ot-var.h
include/harfbuzz/hb-ot.h
include/harfbuzz/hb-paint.h
include/harfbuzz/hb-set.h
include/harfbuzz/hb-shape-plan.h
include/harfbuzz/hb-shape.h
include/harfbuzz/hb-style.h
include/harfbuzz/hb-subset-repacker.h
include/harfbuzz/hb-subset.h
include/harfbuzz/hb-unicode.h
include/harfbuzz/hb-version.h
include/harfbuzz/hb.h
lib/cmake/
lib/cmake/harfbuzz/
lib/cmake/harfbuzz/harfbuzz-config.cmake
lib/girepository-1.0/
lib/girepository-1.0/HarfBuzz-0.0.typelib
@lib lib/libharfbuzz-cairo.so.${LIBharfbuzz-cairo_VERSION}
@lib lib/libharfbuzz-gobject.so.${LIBharfbuzz-gobject_VERSION}
@lib lib/libharfbuzz-subset.so.${LIBharfbuzz-subset_VERSION}
@lib lib/libharfbuzz.so.${LIBharfbuzz_VERSION}
lib/pkgconfig/harfbuzz-cairo.pc
lib/pkgconfig/harfbuzz-gobject.pc
lib/pkgconfig/harfbuzz-subset.pc
lib/pkgconfig/harfbuzz.pc
share/gir-1.0/
share/gir-1.0/HarfBuzz-0.0.gir