SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

50
devel/grcs/Makefile Normal file
View file

@ -0,0 +1,50 @@
COMMENT= GNU versions of the rcs utilities
DISTNAME= rcs-5.9.4
PKGNAME= g${DISTNAME}
REVISION= 4
CATEGORIES= devel
HOMEPAGE= https://www.gnu.org/software/rcs/
# GPLv3
PERMIT_PACKAGE= Yes
WANTLIB= c
MASTER_SITES= ${MASTER_SITE_GNU:=rcs/}
EXTRACT_SUFX= .tar.xz
RUN_DEPENDS= textproc/gdiff
BUILD_DEPENDS= textproc/gdiff
# Uses soelim(1) and pic(1) for preprocessing at build time,
# but the resulting man(7) manuals work with mandoc(1),
# so USE_GROFF is not needed.
BUILD_DEPENDS+= textproc/groff
USE_GMAKE= Yes
CONFIGURE_STYLE=autoconf
AUTOCONF_VERSION=2.69
CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
DIFF="${LOCALBASE}/bin/gdiff" \
DIFF3="${LOCALBASE}/bin/gdiff3"
MODGNU_CONFIG_GUESS_DIRS=${WRKSRC}/build-aux
pre-install:
.for f in ci co rcsclean rcsdiff rcsmerge rlog
sed -i 's/d"rcs/d"grcs/' ${WRKSRC}/src/${f}
.endfor
# handle --program-prefix: The tests use the commands in ${WRKSRC}/src without
# prefix but the wrapper scripts like gci call the command with the prefix.
pre-test:
.for f in ci co ident merge rcs rcsclean rcsdiff rcsmerge rlog
ln -fs ${WRKSRC}/src/$f ${WRKSRC}/src/g$f
.endfor
.include <bsd.port.mk>

2
devel/grcs/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (rcs-5.9.4.tar.xz) = Bj1aDX2hghdUuAxjnNriyCtTXI/0Ex913Hu/DNY6Xf8=
SIZE (rcs-5.9.4.tar.xz) = 801360

View file

@ -0,0 +1,15 @@
Don't use printf %n.
https://git.savannah.gnu.org/cgit/gnulib.git/commit/lib/vasnprintf.c?id=b954346c6101860c7b462d1b286641d1307afd6c
Index: lib/vasnprintf.c
--- lib/vasnprintf.c.orig
+++ lib/vasnprintf.c
@@ -4858,7 +4858,7 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *lengthp,
#endif
*fbp = dp->conversion;
#if USE_SNPRINTF
-# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
+# if 0
fbp[1] = '%';
fbp[2] = 'n';
fbp[3] = '\0';

View file

@ -0,0 +1,11 @@
--- src/b-peer.c.orig Fri Jan 9 10:40:02 2015
+++ src/b-peer.c Wed Mar 16 19:35:59 2016
@@ -25,7 +25,7 @@
#include "b-complain.h"
#include "b-divvy.h"
-struct symdef peer_super = { .meaningful = "rcs", .underlying = NULL };
+struct symdef peer_super = { .meaningful = "grcs", .underlying = NULL };
const char *
one_beyond_last_dir_sep (const char *name)

View file

@ -0,0 +1,12 @@
Index: src/base.h
--- src/base.h.orig
+++ src/base.h
@@ -41,7 +41,7 @@
#include <vfork.h>
#endif
-#define exiting _Noreturn
+#define exiting __dead
/* GCC attributes */

9
devel/grcs/pkg/DESCR Normal file
View file

@ -0,0 +1,9 @@
GNU versions of rcs utilities. The Revision Control System (RCS)
manages multiple revisions of files. RCS automates the storing,
retrieval, logging, identification, and merging of revisions. RCS is
useful for text that is revised frequently, including source code,
programs, documentation, graphics, papers, and form letters.
Note that this port will install these utilities with a 'g' prefix,
e.g. grcs, but the documentation will refer to them without the
'g' prefix.

20
devel/grcs/pkg/PLIST Normal file
View file

@ -0,0 +1,20 @@
bin/gci
bin/gco
@bin bin/gident
@bin bin/gmerge
@bin bin/grcs
bin/grcsclean
bin/grcsdiff
bin/grcsmerge
bin/grlog
@info info/rcs.info
@man man/man1/gci.1
@man man/man1/gco.1
@man man/man1/gident.1
@man man/man1/gmerge.1
@man man/man1/grcs.1
@man man/man1/grcsclean.1
@man man/man1/grcsdiff.1
@man man/man1/grcsmerge.1
@man man/man1/grlog.1
@man man/man5/grcsfile.5