SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,20 @@
COMMENT = Device Firmware Update-based programmer for Atmel chips
DISTNAME = dfu-programmer-0.7.2
CATEGORIES = devel
HOMEPAGE = http://dfu-programmer.github.io/
# GPLv2+
PERMIT_PACKAGE = Yes
WANTLIB = c usb-1.0
MASTER_SITES = ${MASTER_SITE_SOURCEFORGE:=dfu-programmer/}
LIB_DEPENDS = devel/libusb1
CONFIGURE_STYLE = gnu
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (dfu-programmer-0.7.2.tar.gz) = HbTTaxrtqyrcl26PqlSV3zz4LcS/iDYz3GunH3xK+ZU=
SIZE (dfu-programmer-0.7.2.tar.gz) = 146613

View file

@ -0,0 +1,11 @@
Index: src/atmel.c
--- src/atmel.c.orig
+++ src/atmel.c
@@ -21,6 +21,7 @@
#include <stdio.h>
#include <stdarg.h>
#include <stdint.h>
+#include <stdlib.h>
#include <string.h>
#include <stddef.h>
#include <errno.h>

View file

@ -0,0 +1,2 @@
dfu-programmer is a Device Firmware Update based USB programmer for
Atmel chips with a USB bootloader.

View file

@ -0,0 +1,2 @@
@bin bin/dfu-programmer
@man man/man1/dfu-programmer.1