SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
31
devel/cpp-hocon/patches/patch-lib_CMakeLists_txt
Normal file
31
devel/cpp-hocon/patches/patch-lib_CMakeLists_txt
Normal file
|
@ -0,0 +1,31 @@
|
|||
Unbreak due to upstream fixing problems created by leatherman, and we
|
||||
have leatherman fixed in the first place.
|
||||
|
||||
Index: lib/CMakeLists.txt
|
||||
--- lib/CMakeLists.txt.orig
|
||||
+++ lib/CMakeLists.txt
|
||||
@@ -76,19 +76,19 @@ set(PROJECT_SOURCES
|
||||
add_library(libprojectsrc OBJECT ${PROJECT_SOURCES})
|
||||
set_target_properties(libprojectsrc PROPERTIES POSITION_INDEPENDENT_CODE true)
|
||||
|
||||
-add_library(lib${PROJECT_NAME} $<TARGET_OBJECTS:libprojectsrc>)
|
||||
-set_target_properties(lib${PROJECT_NAME} PROPERTIES VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
|
||||
-target_link_libraries(lib${PROJECT_NAME}
|
||||
+add_library(${PROJECT_NAME} $<TARGET_OBJECTS:libprojectsrc>)
|
||||
+set_target_properties(${PROJECT_NAME} PROPERTIES VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
|
||||
+target_link_libraries(${PROJECT_NAME}
|
||||
${LEATHERMAN_LIBRARIES}
|
||||
${Boost_LIBRARIES}
|
||||
)
|
||||
|
||||
# Generate the export header for restricting symbols exported from the library.
|
||||
# Restricting symbols has several advantages, noted at https://gcc.gnu.org/wiki/Visibility.
|
||||
-symbol_exports(lib${PROJECT_NAME} "${CMAKE_CURRENT_LIST_DIR}/inc/hocon/export.h")
|
||||
+symbol_exports(${PROJECT_NAME} "${CMAKE_CURRENT_LIST_DIR}/inc/hocon/export.h")
|
||||
|
||||
# This correctly handles DLL installation on Windows.
|
||||
-leatherman_install(lib${PROJECT_NAME})
|
||||
+leatherman_install(${PROJECT_NAME})
|
||||
install(DIRECTORY inc/hocon DESTINATION include)
|
||||
|
||||
add_subdirectory(tests)
|
35
devel/cpp-hocon/patches/patch-lib_tests_CMakeLists_txt
Normal file
35
devel/cpp-hocon/patches/patch-lib_tests_CMakeLists_txt
Normal file
|
@ -0,0 +1,35 @@
|
|||
Unbreak due to upstream fixing problems created by leatherman, and we
|
||||
have leatherman fixed in the first place.
|
||||
|
||||
Index: lib/tests/CMakeLists.txt
|
||||
--- lib/tests/CMakeLists.txt.orig
|
||||
+++ lib/tests/CMakeLists.txt
|
||||
@@ -18,23 +18,23 @@ set(TEST_CASES
|
||||
program_options.cc
|
||||
)
|
||||
|
||||
-add_executable(lib${PROJECT_NAME}_test $<TARGET_OBJECTS:libprojectsrc> ${TEST_CASES} main.cc)
|
||||
+add_executable(${PROJECT_NAME}_test $<TARGET_OBJECTS:libprojectsrc> ${TEST_CASES} main.cc)
|
||||
|
||||
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
|
||||
- target_link_libraries(lib${PROJECT_NAME}_test rt)
|
||||
+ target_link_libraries(${PROJECT_NAME}_test rt)
|
||||
endif()
|
||||
|
||||
-target_link_libraries(lib${PROJECT_NAME}_test
|
||||
+target_link_libraries(${PROJECT_NAME}_test
|
||||
${Boost_LIBRARIES}
|
||||
${LEATHERMAN_LIBRARIES}
|
||||
${CMAKE_THREAD_LIBS_INIT}
|
||||
)
|
||||
|
||||
if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND BOOST_STATIC AND LEATHERMAN_USE_LOCALES)
|
||||
- target_link_libraries(lib${PROJECT_NAME}_test iconv)
|
||||
+ target_link_libraries(${PROJECT_NAME}_test iconv)
|
||||
endif()
|
||||
|
||||
-add_test(NAME "unit_tests" COMMAND lib${PROJECT_NAME}_test)
|
||||
+add_test(NAME "unit_tests" COMMAND ${PROJECT_NAME}_test)
|
||||
|
||||
configure_file (
|
||||
"${CMAKE_CURRENT_LIST_DIR}/fixtures.hpp.in"
|
Loading…
Add table
Add a link
Reference in a new issue