SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
42
devel/codeworker/Makefile
Normal file
42
devel/codeworker/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
COMMENT = universal parsing tool & source code generator
|
||||
|
||||
V = 4.5.4
|
||||
PKGNAME = codeworker-${V}
|
||||
REVISION = 6
|
||||
|
||||
CATEGORIES = devel
|
||||
|
||||
HOMEPAGE = http://codeworker.free.fr/
|
||||
|
||||
# LGPL
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
WANTLIB = c m ${COMPILER_LIBCXX}
|
||||
|
||||
COMPILER = base-clang ports-gcc base-gcc
|
||||
|
||||
MASTER_SITES = ${MASTER_SITE_GOOGLECODE:=codeworker/} \
|
||||
http://codeworker.free.fr/downloads/
|
||||
DISTNAME = CodeWorker_SRC${V:S/./_/g}
|
||||
EXTRACT_SUFX = .zip
|
||||
|
||||
MAKE_FLAGS = CXXFLAGS='${CXXFLAGS}' CXX='${CXX}'
|
||||
|
||||
USE_GMAKE = Yes
|
||||
|
||||
NO_TEST = Yes
|
||||
|
||||
WRKDIST=${WRKDIR}/CodeWorker${V:S/./_/g}
|
||||
|
||||
FIX_CRLF_FILES= CGExternalHandling.cpp CGRuntime.cpp CGRuntime.h \
|
||||
CppParsingTree.cpp DtaScriptVariable.h Makefile \
|
||||
ScpStream.cpp UtlDate.cpp UtlDirectory.cpp \
|
||||
UtlTrace.cpp UtlXMLStream.cpp
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKDIST}/codeworker ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKDIST}/libcodeworker.a ${PREFIX}/lib
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/codeworker
|
||||
${INSTALL_DATA} ${WRKSRC}/Documentation/* ${PREFIX}/share/examples/codeworker
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/codeworker/distinfo
Normal file
2
devel/codeworker/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (CodeWorker_SRC4_5_4.zip) = VKj0OaOZtxxzZ9359b50ekw9BY/XrYvpDBH1zHUS6eY=
|
||||
SIZE (CodeWorker_SRC4_5_4.zip) = 3278840
|
18
devel/codeworker/patches/patch-CGExternalHandling_cpp
Normal file
18
devel/codeworker/patches/patch-CGExternalHandling_cpp
Normal file
|
@ -0,0 +1,18 @@
|
|||
Index: CGExternalHandling.cpp
|
||||
--- CGExternalHandling.cpp.orig
|
||||
+++ CGExternalHandling.cpp
|
||||
@@ -185,12 +185,12 @@ namespace CodeWorker {
|
||||
iLength = NetSocket::nToHl(iLength);
|
||||
char* tcInput = new char[iLength + 1];
|
||||
if (!NetSocket::receiveExactlyFromSocket(hSocket_, tcInput, iLength)) {
|
||||
- delete tcInput;
|
||||
+ delete [] tcInput;
|
||||
throw UtlException("Remote debug protocol error: incorrect number of bytes received");
|
||||
}
|
||||
tcInput[iLength] = '\0';
|
||||
std::string sResult = tcInput;
|
||||
- delete tcInput;
|
||||
+ delete [] tcInput;
|
||||
return sResult;
|
||||
}
|
||||
|
12
devel/codeworker/patches/patch-CGRuntime_cpp
Normal file
12
devel/codeworker/patches/patch-CGRuntime_cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: CGRuntime.cpp
|
||||
--- CGRuntime.cpp.orig
|
||||
+++ CGRuntime.cpp
|
||||
@@ -41,6 +41,8 @@ To contact the author: codeworker@free.fr
|
||||
#include <time.h>
|
||||
|
||||
#include <errno.h>
|
||||
+// for EXIT_FAILURE
|
||||
+#include <stdlib.h>
|
||||
|
||||
#ifdef CODEWORKER_GNU_READLINE
|
||||
# include <stdio.h> // fix for Red Hat 9 - thanks to Justin Cinkelj
|
13
devel/codeworker/patches/patch-CGRuntime_h
Normal file
13
devel/codeworker/patches/patch-CGRuntime_h
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fix a lot of include errors with ports-gcc
|
||||
Index: CGRuntime.h
|
||||
--- CGRuntime.h.orig
|
||||
+++ CGRuntime.h
|
||||
@@ -24,6 +24,8 @@ To contact the author: codeworker@free.fr
|
||||
|
||||
#include <string>
|
||||
#include <list>
|
||||
+#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
|
||||
#include "UtlException.h"
|
||||
#include "CppParsingTree.h"
|
12
devel/codeworker/patches/patch-CppParsingTree_cpp
Normal file
12
devel/codeworker/patches/patch-CppParsingTree_cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
CppParsingTree.cpp:113:22: error: 'atoi' was not declared in this scope
|
||||
Index: CppParsingTree.cpp
|
||||
--- CppParsingTree.cpp.orig
|
||||
+++ CppParsingTree.cpp
|
||||
@@ -25,6 +25,7 @@ To contact the author: codeworker@free.fr
|
||||
|
||||
#ifndef WIN32
|
||||
# include <cstdio> // for Debian/gcc 2.95.4
|
||||
+# include <stdlib.h>
|
||||
#endif
|
||||
|
||||
#include "ScpStream.h"
|
11
devel/codeworker/patches/patch-DtaScriptVariable_h
Normal file
11
devel/codeworker/patches/patch-DtaScriptVariable_h
Normal file
|
@ -0,0 +1,11 @@
|
|||
Index: DtaScriptVariable.h
|
||||
--- DtaScriptVariable.h.orig
|
||||
+++ DtaScriptVariable.h
|
||||
@@ -32,6 +32,7 @@ To contact the author: codeworker@free.fr
|
||||
# endif
|
||||
#endif
|
||||
|
||||
+#include <cstring>
|
||||
#include <string>
|
||||
#include <list>
|
||||
#include <vector>
|
13
devel/codeworker/patches/patch-Makefile
Normal file
13
devel/codeworker/patches/patch-Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.orig Thu May 13 18:12:11 2010
|
||||
+++ Makefile Thu May 13 18:12:19 2010
|
||||
@@ -150,8 +150,8 @@ all: build lib
|
||||
build: codeworker
|
||||
|
||||
codeworker: $(OBJECTS)
|
||||
- $(CC) -c generator.cpp
|
||||
- $(CC) -o codeworker $(OBJECTS) generator.o $(LFLAGS)
|
||||
+ $(CXX) -c generator.cpp
|
||||
+ $(CXX) -o codeworker $(OBJECTS) generator.o $(LDFLAGS)
|
||||
|
||||
lib: $(OBJECTS)
|
||||
ar -r libcodeworker.a $(OBJECTS)
|
13
devel/codeworker/patches/patch-ScpStream_cpp
Normal file
13
devel/codeworker/patches/patch-ScpStream_cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fix numerous include errors with ports-gcc
|
||||
Index: ScpStream.cpp
|
||||
--- ScpStream.cpp.orig
|
||||
+++ ScpStream.cpp
|
||||
@@ -28,6 +28,8 @@ To contact the author: codeworker@free.fr
|
||||
# include <sys/stat.h>
|
||||
// functions 'ntohl()' and 'htonl()'
|
||||
# include <netinet/in.h>
|
||||
+# include <string.h>
|
||||
+# include <stdlib.h>
|
||||
#endif
|
||||
|
||||
#include "UtlException.h"
|
13
devel/codeworker/patches/patch-UtlDate_cpp
Normal file
13
devel/codeworker/patches/patch-UtlDate_cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fix several include errors with ports-gcc
|
||||
Index: UtlDate.cpp
|
||||
--- UtlDate.cpp.orig
|
||||
+++ UtlDate.cpp
|
||||
@@ -26,6 +26,8 @@ To contact the author: codeworker@free.fr
|
||||
#include <stdio.h>
|
||||
#include <math.h>
|
||||
#include <time.h>
|
||||
+#include <string.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#ifdef WIN32
|
||||
# include <windows.h>
|
13
devel/codeworker/patches/patch-UtlDirectory_cpp
Normal file
13
devel/codeworker/patches/patch-UtlDirectory_cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
fix various include errors with ports-gcc
|
||||
Index: UtlDirectory.cpp
|
||||
--- UtlDirectory.cpp.orig
|
||||
+++ UtlDirectory.cpp
|
||||
@@ -30,6 +30,8 @@ To contact the author: codeworker@free.fr
|
||||
# include <sys/stat.h>
|
||||
# include <unistd.h>
|
||||
# include <glob.h>
|
||||
+# include <stdlib.h>
|
||||
+# include <string.h>
|
||||
#endif
|
||||
|
||||
#include "UtlException.h"
|
12
devel/codeworker/patches/patch-UtlTrace_cpp
Normal file
12
devel/codeworker/patches/patch-UtlTrace_cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
fix several include errors with ports-gcc
|
||||
Index: UtlTrace.cpp
|
||||
--- UtlTrace.cpp.orig
|
||||
+++ UtlTrace.cpp
|
||||
@@ -24,6 +24,7 @@ To contact the author: codeworker@free.fr
|
||||
#endif
|
||||
|
||||
#include <stdarg.h>
|
||||
+#include <string.h>
|
||||
#include "ScpStream.h"
|
||||
#include "UtlTrace.h"
|
||||
|
12
devel/codeworker/patches/patch-UtlXMLStream_cpp
Normal file
12
devel/codeworker/patches/patch-UtlXMLStream_cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
fix several include errors with ports-gcc
|
||||
Index: UtlXMLStream.cpp
|
||||
--- UtlXMLStream.cpp.orig
|
||||
+++ UtlXMLStream.cpp
|
||||
@@ -28,6 +28,7 @@ To contact the author: codeworker@free.fr
|
||||
#include "UtlException.h"
|
||||
#include "ScpStream.h"
|
||||
#include "UtlXMLStream.h"
|
||||
+#include <string.h>
|
||||
|
||||
namespace CodeWorker {
|
||||
UtlXMLStream::UtlXMLStream(const std::string& sFileName, const bool bModeRead) : _bOwnerOfFileStream(true), _pInputStream(NULL), _pOutputStream(NULL) {
|
4
devel/codeworker/pkg/DESCR
Normal file
4
devel/codeworker/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
CodeWorker is a versatile Open Source parsing tool and a source code
|
||||
generator devoted to generative programming. Generative programming is a
|
||||
software engineering approach interested in automating the production of
|
||||
reusable, tailor-made, adaptable and reliable IT systems.
|
45
devel/codeworker/pkg/PLIST
Normal file
45
devel/codeworker/pkg/PLIST
Normal file
|
@ -0,0 +1,45 @@
|
|||
@bin bin/codeworker
|
||||
lib/libcodeworker.a
|
||||
share/examples/codeworker/
|
||||
share/examples/codeworker/AOP-example1.cwt
|
||||
share/examples/codeworker/AOP-example1.txt
|
||||
share/examples/codeworker/CodeWorker.css
|
||||
share/examples/codeworker/CodeWorker.tex
|
||||
share/examples/codeworker/Debugger.cmd
|
||||
share/examples/codeworker/FinallySample.cws
|
||||
share/examples/codeworker/ForeachSampleFirst.cws
|
||||
share/examples/codeworker/ForeachSampleLast.cws
|
||||
share/examples/codeworker/ForeachSampleSorted.cws
|
||||
share/examples/codeworker/ForfileSample.cws
|
||||
share/examples/codeworker/GeneratingExamples.cwt
|
||||
share/examples/codeworker/GeneratingExamplesBuilder.cwt
|
||||
share/examples/codeworker/GeneratingSample.txt
|
||||
share/examples/codeworker/IndentSample.cpp
|
||||
share/examples/codeworker/IndentSample.txt
|
||||
share/examples/codeworker/LastChanges.html
|
||||
share/examples/codeworker/MatchingStructure.txt
|
||||
share/examples/codeworker/ParsingExamples.cws
|
||||
share/examples/codeworker/ParsingExamplesBuilder.cwt
|
||||
share/examples/codeworker/ParsingSample.txt
|
||||
share/examples/codeworker/Planet.java
|
||||
share/examples/codeworker/SelectSample.cws
|
||||
share/examples/codeworker/SolarSystem.java
|
||||
share/examples/codeworker/System.cws
|
||||
share/examples/codeworker/System.out
|
||||
share/examples/codeworker/boilerplate.tex
|
||||
share/examples/codeworker/build.bat
|
||||
share/examples/codeworker/copyright.tex
|
||||
share/examples/codeworker/distutils.sty
|
||||
share/examples/codeworker/doc.bat
|
||||
share/examples/codeworker/doc_begin.bat
|
||||
share/examples/codeworker/doc_end.bat
|
||||
share/examples/codeworker/english.txt
|
||||
share/examples/codeworker/fancyhdr.sty
|
||||
share/examples/codeworker/fncychap.sty
|
||||
share/examples/codeworker/french.txt
|
||||
share/examples/codeworker/howto.cls
|
||||
share/examples/codeworker/license.tex
|
||||
share/examples/codeworker/ltxmarkup.sty
|
||||
share/examples/codeworker/manual.cls
|
||||
share/examples/codeworker/pypaper.sty
|
||||
share/examples/codeworker/python.sty
|
Loading…
Add table
Add a link
Reference in a new issue