SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,12 @@
Index: bootstrap
--- bootstrap.orig
+++ bootstrap
@@ -64,7 +64,7 @@ rm -rf autom4te.cache
# Make the build more robust if a Makefile.am is removed from the file system, but it is not removed
# from the configure.ac file.
-find . | grep -v wxSmithSTC/stc| grep Makefile.in$ | xargs rm -v
+find . | grep -v wxSmithSTC/stc| grep Makefile.in$ | xargs -r rm -v
rm -vf debian/control
echo "Note: If you want to build debian packages you have to first run the debian/setup_control.sh script. See the script for details how to use it."

View file

@ -0,0 +1,14 @@
undefined reference to `free'
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -42,8 +42,6 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_AWK
-CODEBLOCKS_CHECK_LINK_FLAG([-Wl,--no-undefined],[LDFLAGS="-Wl,--no-undefined $LDFLAGS"])
-
CODEBLOCKS_SETUP_FOR_TARGET
dnl Checks for header files.

View file

@ -0,0 +1,15 @@
Make sure bundled tinyxml is ahead of system tinyxml in search path
Index: src/base/tinyxml/Makefile.am
--- src/base/tinyxml/Makefile.am.orig
+++ src/base/tinyxml/Makefile.am
@@ -1,7 +1,8 @@
AM_CPPFLAGS = $(WX_CXXFLAGS) \
-I$(top_srcdir)/src/sdk/wxscintilla/include \
-I$(top_srcdir)/src/include \
- -I$(top_srcdir)/src/include/tinyxml
+ -I$(top_srcdir)/src/include/tinyxml \
+ $(WX_CXXFLAGS)
noinst_LTLIBRARIES = libtinyxml.la

View file

@ -0,0 +1,236 @@
r12841 | wh11204 | 2022-06-29 14:34:36 +0200 (Wed, 29 Jun 2022) | 4 lines
* Fix compilation of wx3.1.6 and later with Clang (thanks AndrewCot).
See https://forums.codeblocks.org/index.php/topic,25004.msg170429.html#msg170429
Also fix some typos in documentation.
r12842 | wh11204 | 2022-06-30 11:36:18 +0200 (Thu, 30 Jun 2022) | 3 lines
- Complete previous commit, InsertPage() must be fixed too.
It appeared in the diff, but I forgot about it when editing.
Index: src/include/cbauibook.h
--- src/include/cbauibook.h.orig
+++ src/include/cbauibook.h
@@ -57,14 +57,14 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Loads serialized notebook layout
* \param layout the serialized layout
* \param mergeLayouts try to merge the tab-layouts
- * \return bool true if successfull
+ * \return bool true if successful
*
*/
bool LoadPerspective(const wxString& layout, bool mergeLayouts = false);
- /** \brief Get the tab index from tooltiptext
+ /** \brief Get the tab index from tooltip text
* \param text the notebooks name
* \return int the tab's index
- * @remarks We use the name internally to store the tooltip-text. To use it
+ * @remarks We use the name internally to store the tooltip text. To use it
* in this function, we create a unique string from the relative filename
* and the projects title. So it should be unique even after a
* restart of C::B.
@@ -78,7 +78,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
* \return int the visible position
*/
int GetTabPositionFromIndex(int index);
- /** \brief Minmize free horizontal page
+ /** \brief Minimize free horizontal page
*
* Moves the active tab of all tabCtrl's to the rightmost place,
* to show as many tabs as possible.
@@ -87,21 +87,21 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Delete Page
*
* Calls the base-class function and after that
- * MinmizeFreeSpace(), needed to hook into the close-events.
+ * MinimizeFreeSpace(), needed to hook into the close-events.
* The system generated close event has to be veto'd, and Close()
* has to be called manually, so we can handle it ourselves.
* \param The index of the tab to be closed
- * \return true if successfull
+ * \return true if successful
*/
bool DeletePage(size_t page) override;
/** \brief Remove Page
*
* Calls the base-class function and after that
- * MinmizeFreeSpace(), needed to hook into the close-events.
+ * MinimizeFreeSpace(), needed to hook into the close-events.
* The system generated close event has to be veto'd, and Close()
* has to be called manually, so we can handle it ourselves.
* \param The index of the tab to be closed
- * \return true if successfull
+ * \return true if successful
*/
bool RemovePage(size_t page) override;
/** \brief Move page
@@ -109,44 +109,52 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
* Moves the tab containing page to new_idx
* \param page The page to move (e.g. cbEditor*)
* \param new_idx The index the page should be moved to
- * \return true if successfull
+ * \return true if successful
*/
bool MovePage(wxWindow* page, size_t new_idx);
/** \brief Add Page
*
* Calls the base-class function and after that
- * MinmizeFreeSpace().
+ * MinimizeFreeSpace().
* \param page The page to add
* \param caption The caption of the page
* \param select If true the page gets selected
- * \param bitmap The bitmap of the tab
- * \return true if successfull
+ * \param bitmap The bitmap (or bitmap bundle since wx3.1.6) of the tab
+ * \return true if successful
*/
bool AddPage(wxWindow* page,
const wxString& caption,
bool select = false,
+#if wxCHECK_VERSION(3, 1, 6)
+ const wxBitmapBundle& bitmap = wxBitmapBundle());
+#else
const wxBitmap& bitmap = wxNullBitmap);
+#endif
/** \brief Insert Page
*
* Calls the base-class function and after that
- * MinmizeFreeSpace().
+ * MinimizeFreeSpace().
* \param page_idx The index where the page should be inserted
* \param page The page to add
* \param caption The caption of the page
* \param select If true the page gets selected
- * \param bitmap The bitmap of the tab
- * \return true if successfull
+ * \param bitmap The bitmap (or bitmap bundle since wx3.1.6) of the tab
+ * \return true if successful
*/
bool InsertPage(size_t page_idx,
wxWindow* page,
const wxString& caption,
bool select = false,
+#if wxCHECK_VERSION(3, 1, 6)
+ const wxBitmapBundle& bitmap = wxBitmapBundle());
+#else
const wxBitmap& bitmap = wxNullBitmap);
- /** \brief Set zoomfactor for builtin editors
+#endif
+ /** \brief Set zoom factor for builtin editors
*
- * Sets the zoomfactor for all visible builtin
+ * Sets the zoom factor for all visible builtin
* editors.
- * \param zoom zoomfactor to use
+ * \param zoom zoom factor to use
*/
void SetZoom(int zoom);
/** \brief Set Focus on the tabCtrl belonging to the active tab
@@ -165,7 +173,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Create a unique id from the tooltip-text
*
* Tries to create a unique id from the tooltip.
- * Find the projectfile, geet the relative filename and put it
+ * Find the projectfile, get the relative filename and put it
* together with the projects name.
* We use it to save and load the pane layout.
* By using the relative filename, it works even if the project
@@ -173,7 +181,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
* \param text The tooltip text
*/
wxString UniqueIdFromTooltip(const wxString& text);
- /** \brief Minmize free horizontal page of tabCtrl
+ /** \brief Minimize free horizontal page of tabCtrl
*
* Moves the active tab of tabCtrl to the rightmost place,
* to show as many tabs as possible.
@@ -194,7 +202,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
void OnIdle(cb_unused wxIdleEvent& event);
/** \brief Catch doubleclick-events from wxTabCtrl
*
- * Sends cbEVT_CBAUIBOOK_LEFT_DCLICK, if doubleclick was on a tab,
+ * Sends cbEVT_CBAUIBOOK_LEFT_DCLICK, if double click was on a tab,
* event-Id is the notebook-Id, event-object is the pointer to the window the
* tab belongs to.
* \param event holds the wxTabCtrl, that sends the event
@@ -202,7 +210,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
void OnTabCtrlDblClick(wxMouseEvent& event);
/** \brief Catch mousewheel-events from wxTabCtrl
*
- * Sends cbEVT_CBAUIBOOK_MOUSEWHEEL, if doubleclick was on a tab,
+ * Sends cbEVT_CBAUIBOOK_MOUSEWHEEL, if double click was on a tab,
* event-Id is the notebook-Id, event-object is the pointer to the window the
* tab belongs to.
* \param event holds the wxTabCtrl, that sends the event
@@ -229,7 +237,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
* \param event holds the wxTabCtrl, that sends the event
*/
void OnLeaveTabCtrl(wxMouseEvent& event);
- // hack needed on wxMSW, because only focused windows get mousewheel-events
+ // hack needed on wxMSW, because only focused windows get mouse wheel-events
/** \brief Checks the old focus
*
* Checks whether the old focused window or one of it's
@@ -276,7 +284,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
// needed for wxMSW-hack, see above
/** \brief Last selected tab
*
- * Used to determine whether the tab-selection has changed btween mouseenter
+ * Used to determine whether the tab-selection has changed between mouseenter
* and mouseleave-event.
*/
int m_LastSelected;
@@ -308,7 +316,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
* \param use If true tooltips are allowed
*/
static void UseToolTips(bool use = true);
- /** \brief Enable or disable tab-scrolling with mousewheel
+ /** \brief Enable or disable tab-scrolling with mouse wheel
*
* \param allow If true scrolling is allowed
*/
@@ -316,15 +324,15 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Sets the modifier keys for scrolling
*/
static void SetModKeys(wxString keys = _T("Strg"));
- /** \brief Use modkey to advance through tabs with mousewheel
+ /** \brief Use modkey to advance through tabs with mouse wheel
*/
static void UseModToAdvance(bool use = false);
- /** \brief Change direction of tab-advancing with mousewheel
+ /** \brief Change direction of tab-advancing with mouse wheel
*
* \param invert If true advance direction is inverted
*/
static void InvertAdvanceDirection(bool invert = false);
- /** \brief Change direction of tab-moving with mousewheel
+ /** \brief Change direction of tab-moving with mouse wheel
*
* \param invert If true move direction is inverted
*/
@@ -333,7 +341,7 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Enable or disable tab tooltips
*/
static bool s_UseTabTooltips;
- /** \brief Enable or disable scrolling tabs with mousewheel
+ /** \brief Enable or disable scrolling tabs with mouse wheel
*/
static bool s_AllowMousewheel;
/** \brief Holds an array of all existing cbAuiNotebooks
@@ -342,13 +350,13 @@ class DLLIMPORT cbAuiNotebook : public wxAuiNotebook
/** \brief Holds the modifier keys for scrolling
*/
static wxString s_modKeys;
- /** \brief Use modkey to advance through tabs with mousewheel
+ /** \brief Use modkey to advance through tabs with mouse wheel
*/
static bool s_modToAdvance;
- /** \brief Mousewheel move direction: negative => invert
+ /** \brief Mouse wheel move direction: negative => invert
*/
static int s_moveDirection;
- /** \brief Mouseweheel advance direction: negative => invert
+ /** \brief Mouse wheel advance direction: negative => invert
*/
static int s_advanceDirection;

View file

@ -0,0 +1,50 @@
Always use cb_console_runner from installed PREFIX.
Index: src/plugins/compilergcc/compilergcc.cpp
--- src/plugins/compilergcc/compilergcc.cpp.orig
+++ src/plugins/compilergcc/compilergcc.cpp
@@ -166,7 +166,7 @@ namespace
{
PluginRegistrant<CompilerGCC> reg(_T("Compiler"));
- static const wxString strCONSOLE_RUNNER(platform::windows ? _T("cb_console_runner.exe") : _T("cb_console_runner"));
+ static const wxString strCONSOLE_RUNNER(platform::windows ? _T("cb_console_runner.exe") : _T("${PREFIX}/bin/cb_console_runner"));
static const wxString strSLASH(_T("/"));
static const wxString strSPACE(_T(" "));
static const wxString strQUOTE(platform::windows ? _T("\"") : _T("'"));
@@ -1855,8 +1855,7 @@ int CompilerGCC::RunSingleFile(const wxString& filenam
wxString baseDir = ConfigManager::GetExecutableFolder();
wxString crunnStr = strQUOTE + baseDir + strSLASH + strCONSOLE_RUNNER + strQUOTE;
- if ( wxFileExists(baseDir + strSLASH + strCONSOLE_RUNNER) )
- command << crunnStr << strSPACE;
+ command << strCONSOLE_RUNNER << strSPACE;
if (!command.Replace(_T("$SCRIPT"), exe_filename))
command << strQUOTE << exe_filename << strQUOTE; // if they didn't specify $SCRIPT, append:
@@ -1973,7 +1972,7 @@ int CompilerGCC::Run(ProjectBuildTarget* target)
: EscapeSpaces(m_CdRun);
wxString crunnStr = platform::windows
? strQUOTE + baseDir + strSLASH + strCONSOLE_RUNNER + strQUOTE
- : EscapeSpaces(baseDir + strSLASH + strCONSOLE_RUNNER);
+ : EscapeSpaces(strCONSOLE_RUNNER);
wxString hostapStr = platform::windows
? strQUOTE + target->GetHostApplication() + strQUOTE
: EscapeSpaces(target->GetHostApplication());
@@ -2011,8 +2010,6 @@ int CompilerGCC::Run(ProjectBuildTarget* target)
if (target->GetUseConsoleRunner())
{
- if (wxFileExists(baseDir + strSLASH + strCONSOLE_RUNNER))
- {
command << crunnStr << strSPACE;
if (!platform::windows)
@@ -2024,7 +2021,6 @@ int CompilerGCC::Run(ProjectBuildTarget* target)
QuoteStringIfNeeded(strLinkerPath);
command << strLinkerPath << strSPACE;
}
- }
}
}

View file

@ -0,0 +1,15 @@
Guard the trap with LOGGING
Index: src/plugins/contrib/dragscroll/dragscrollcfg.h
--- src/plugins/contrib/dragscroll/dragscrollcfg.h.orig
+++ src/plugins/contrib/dragscroll/dragscrollcfg.h
@@ -35,7 +35,9 @@ class cbDragScrollCfg: public cbConfigurationPanel
wxString GetBitmapBaseName() const;
void OnApply();
void OnCancel(){}
+#if defined(LOGGING)
virtual void InitDialog() { } /*trap*/
+#endif
// pointer to owner of the configuration diaglog needed to
// complete the OnApply/OnCancel EndModal() logic

View file

@ -0,0 +1,36 @@
r12841 | wh11204 | 2022-06-29 14:34:36 +0200 (Wed, 29 Jun 2022) | 4 lines
* Fix compilation of wx3.1.6 and later with Clang (thanks AndrewCot).
See https://forums.codeblocks.org/index.php/topic,25004.msg170429.html#msg170429
Also fix some typos in documentation.
r12842 | wh11204 | 2022-06-30 11:36:18 +0200 (Thu, 30 Jun 2022) | 3 lines
- Complete previous commit, InsertPage() must be fixed too.
It appeared in the diff, but I forgot about it when editing.
Index: src/sdk/cbauibook.cpp
--- src/sdk/cbauibook.cpp.orig
+++ src/sdk/cbauibook.cpp
@@ -500,7 +500,11 @@ bool cbAuiNotebook::MovePage(wxWindow* page, size_t ne
bool cbAuiNotebook::AddPage(wxWindow* page,
const wxString& caption,
bool select,
+#if wxCHECK_VERSION(3, 1, 6)
+ const wxBitmapBundle& bitmap)
+#else
const wxBitmap& bitmap)
+#endif
{
bool result = wxAuiNotebook::AddPage(page, caption, select, bitmap);
MinimizeFreeSpace();
@@ -511,7 +515,11 @@ bool cbAuiNotebook::InsertPage(size_t page_idx,
wxWindow* page,
const wxString& caption,
bool select,
+#if wxCHECK_VERSION(3, 1, 6)
+ const wxBitmapBundle& bitmap)
+#else
const wxBitmap& bitmap)
+#endif
{
bool result = wxAuiNotebook::InsertPage(page_idx, page, caption, select, bitmap);
MinimizeFreeSpace();

View file

@ -0,0 +1,56 @@
Index: src/sdk/mozilla_chardet/include/nsprpub/pr/include/prcpucfg_linux.h
--- src/sdk/mozilla_chardet/include/nsprpub/pr/include/prcpucfg_linux.h.orig
+++ src/sdk/mozilla_chardet/include/nsprpub/pr/include/prcpucfg_linux.h
@@ -643,6 +643,52 @@
#define PR_BYTES_PER_WORD_LOG2 3
#define PR_BYTES_PER_DWORD_LOG2 3
+#elif defined(__riscv) && __riscv_xlen == 64
+
+#define IS_LITTLE_ENDIAN 1
+#undef IS_BIG_ENDIAN
+#define IS_64
+
+#define PR_BYTES_PER_BYTE 1
+#define PR_BYTES_PER_SHORT 2
+#define PR_BYTES_PER_INT 4
+#define PR_BYTES_PER_INT64 8
+#define PR_BYTES_PER_LONG 8
+#define PR_BYTES_PER_FLOAT 4
+#define PR_BYTES_PER_DOUBLE 8
+#define PR_BYTES_PER_WORD 8
+#define PR_BYTES_PER_DWORD 8
+
+#define PR_BITS_PER_BYTE 8
+#define PR_BITS_PER_SHORT 16
+#define PR_BITS_PER_INT 32
+#define PR_BITS_PER_INT64 64
+#define PR_BITS_PER_LONG 64
+#define PR_BITS_PER_FLOAT 32
+#define PR_BITS_PER_DOUBLE 64
+#define PR_BITS_PER_WORD 64
+
+#define PR_BITS_PER_BYTE_LOG2 3
+#define PR_BITS_PER_SHORT_LOG2 4
+#define PR_BITS_PER_INT_LOG2 5
+#define PR_BITS_PER_INT64_LOG2 6
+#define PR_BITS_PER_LONG_LOG2 6
+#define PR_BITS_PER_FLOAT_LOG2 5
+#define PR_BITS_PER_DOUBLE_LOG2 6
+#define PR_BITS_PER_WORD_LOG2 6
+
+#define PR_ALIGN_OF_SHORT 2
+#define PR_ALIGN_OF_INT 4
+#define PR_ALIGN_OF_LONG 8
+#define PR_ALIGN_OF_INT64 8
+#define PR_ALIGN_OF_FLOAT 4
+#define PR_ALIGN_OF_DOUBLE 8
+#define PR_ALIGN_OF_POINTER 8
+#define PR_ALIGN_OF_WORD 8
+
+#define PR_BYTES_PER_WORD_LOG2 3
+#define PR_BYTES_PER_DWORD_LOG2 3
+
#elif defined(__hppa__)
#undef IS_LITTLE_ENDIAN

View file

@ -0,0 +1,11 @@
--- src/src/appglobals.cpp.orig Sun Dec 8 16:00:22 2013
+++ src/src/appglobals.cpp Thu Sep 11 10:31:01 2014
@@ -49,6 +49,8 @@ namespace appglobals
const wxString AppPlatform = _T("Darwin");
#elif defined(__FreeBSD__)
const wxString AppPlatform = _T("FreeBSD");
+#elif defined(__OpenBSD__)
+ const wxString AppPlatform = _T("OpenBSD");
#elif defined(__UNIX__)
const wxString AppPlatform = _T("Linux");
#else