SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
14
devel/ccache/patches/patch-unittest_CMakeLists_txt
Normal file
14
devel/ccache/patches/patch-unittest_CMakeLists_txt
Normal file
|
@ -0,0 +1,14 @@
|
|||
don't build tests by default
|
||||
|
||||
Index: unittest/CMakeLists.txt
|
||||
--- unittest/CMakeLists.txt.orig
|
||||
+++ unittest/CMakeLists.txt
|
||||
@@ -47,7 +47,7 @@ endif()
|
||||
file(GLOB headers *.hpp)
|
||||
list(APPEND source_files ${headers})
|
||||
|
||||
-add_executable(unittest ${source_files})
|
||||
+add_executable(unittest EXCLUDE_FROM_ALL ${source_files})
|
||||
|
||||
if(MSVC AND NOT CMAKE_CXX_COMPILER_ID MATCHES "^Clang$")
|
||||
# Turn off /Zc:preprocessor for this test because it triggers a bug in some older Windows 10 SDK headers.
|
Loading…
Add table
Add a link
Reference in a new issue