SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
20
devel/cbmc/patches/patch-src_xmllang_Makefile
Normal file
20
devel/cbmc/patches/patch-src_xmllang_Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
Newer bison includes the defines file in the parser so the name must match.
|
||||
|
||||
Index: src/xmllang/Makefile
|
||||
--- src/xmllang/Makefile.orig
|
||||
+++ src/xmllang/Makefile
|
||||
@@ -15,12 +15,8 @@ all: xmllang$(LIBEXT)
|
||||
xmllang$(LIBEXT): $(OBJ)
|
||||
$(LINKLIB)
|
||||
|
||||
-xml_y.tab.cpp: parser.y
|
||||
- $(YACC) $(YFLAGS) $$flags -pyyxml -d parser.y -o $@
|
||||
-
|
||||
-xml_y.tab.h: xml_y.tab.cpp
|
||||
- if [ -e xml_y.tab.hpp ] ; then mv xml_y.tab.hpp $@ ; else \
|
||||
- mv xml_y.tab.cpp.h $@ ; fi
|
||||
+xml_y.tab.cpp xml_y.tab.h: parser.y
|
||||
+ $(YACC) $(YFLAGS) $$flags -pyyxml --defines=xml_y.tab.h parser.y -o $@
|
||||
|
||||
xml_lex.yy.cpp: scanner.l
|
||||
$(LEX) -Pyyxml -o$@ scanner.l
|
Loading…
Add table
Add a link
Reference in a new issue