SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,21 @@
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -388,7 +388,7 @@ if test "$GCC" = yes; then
safe_CFLAGS=$CFLAGS
CFLAGS="$ENABLE_WARNINGS -Wno-pointer-sign"
- AC_TRY_COMPILE(, [ int main () { return 0 ; } ], [
+ AC_TRY_COMPILE(, [], [
no_pointer_sign=yes
AC_MSG_RESULT([yes])
], [
@@ -413,7 +413,7 @@ case $target in
safe_CFLAGS="$CFLAGS"
CFLAGS="$ENABLE_WARNINGS -mno-cygwin"
- AC_TRY_COMPILE(, [ int main () { return 0 ; } ], [
+ AC_TRY_COMPILE(, [], [
no_cygwin=yes
AC_MSG_RESULT([yes])
], [