SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
32
devel/avr32/gcc-bootstrap/patches/patch-libgcc_Makefile_in
Normal file
32
devel/avr32/gcc-bootstrap/patches/patch-libgcc_Makefile_in
Normal file
|
@ -0,0 +1,32 @@
|
|||
Prevent 'permission denied' errors during build as non-root user
|
||||
because of attempts to chown files to root.
|
||||
These install targets are run during the build, before 'make fake'.
|
||||
--- libgcc/Makefile.in.orig Fri Apr 10 01:23:07 2009
|
||||
+++ libgcc/Makefile.in Mon Jan 6 16:24:11 2014
|
||||
@@ -99,7 +99,7 @@ all: all-multi
|
||||
# them back to the GCC directory. Too many things (other
|
||||
# in-tree libraries, and DejaGNU) know about the layout
|
||||
# of the build tree, for now.
|
||||
- $(MAKE) install-leaf DESTDIR=$(gcc_objdir) \
|
||||
+ $(MAKE) install-leaf INSTALL_DATA=cp DESTDIR=$(gcc_objdir) \
|
||||
slibdir= libsubdir= MULTIOSDIR=$(MULTIDIR)
|
||||
|
||||
.PHONY: all-multi
|
||||
@@ -857,7 +857,7 @@ endif
|
||||
parts="$(EXTRA_PARTS)"; \
|
||||
for file in $$parts; do \
|
||||
rm -f $(gcc_objdir)$(MULTISUBDIR)/$$file; \
|
||||
- $(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
|
||||
+ cp $$file $(gcc_objdir)$(MULTISUBDIR)/; \
|
||||
done
|
||||
|
||||
# Build extra startfiles in the gcc directory, for unconverted
|
||||
@@ -890,7 +890,7 @@ gcc-extra-parts:
|
||||
parts="$(GCC_EXTRA_PARTS)"; \
|
||||
for file in $$parts; do \
|
||||
rm -f $(gcc_objdir)$(MULTISUBDIR)/$$file; \
|
||||
- $(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
|
||||
+ cp $$file $(gcc_objdir)$(MULTISUBDIR)/; \
|
||||
done
|
||||
|
||||
all: $(extra-parts)
|
Loading…
Add table
Add a link
Reference in a new issue