SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,52 @@
COMMENT = bootstrap compiler for the AVR32 toolchain
V = 4.4.7
DISTNAME = avr32-gcc-${V}
PKGNAME = avr32-gcc-bootstrap-${V}
# GPLv3
PERMIT_PACKAGE = Yes
REVISION = 2
WANTLIB = c gmp mpfr
DIST_SUBDIR = gcc
AUTOCONF_VERSION = 2.59
CONFIGURE_ARGS = --disable-libssp \
--disable-threads \
--disable-libstdcxx-pch \
--with-gmp=${LOCALBASE} \
--with-mpfr-lib=${LOCALBASE} \
--with-mpfr-include=${LOCALBASE} \
--without-headers \
--enable-languages=c \
--exec-prefix=${PREFIX}/avr32/bootstrap \
--with-local-prefix=${PREFIX}/avr32/bootstrap \
--with-as=${LOCALBASE}/bin/avr32-as \
--with-ld=${LOCALBASE}/bin/avr32-ld
WRKDIST = ${WRKDIR}/gcc-${V}
BUILD_DEPENDS = devel/avr32/binutils \
${MODGNU_AUTOCONF_DEPENDS}
RUN_DEPENDS = devel/avr32/binutils
LIB_DEPENDS = devel/gmp \
devel/mpfr
CFLAGS += -fgnu89-inline
SEPARATE_BUILD = Yes
.if ${MACHINE_ARCH} == "powerpc64"
PATCH_LIST = patch-* vecstep-*
.endif
# This file confuses 'make update-patches'
post-extract:
rm ${WRKSRC}/gcc/config/avr32/avr32.c.orig
# Fix configure scripts missing configure.in patches
do-gen:
cd ${WRKSRC}/gcc; ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF}
post-install:
chown -R ${SHAREOWN}:${SHAREGRP} \
${PREFIX}/avr32/bootstrap/lib/gcc/avr32/${V}/include*
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (gcc/avr32-gcc-4.4.7.tar.gz) = HpUmBhHZkE54yUURIKWLN2g57ro1t0MI4hpHeFty0/4=
SIZE (gcc/avr32-gcc-4.4.7.tar.gz) = 83319635

View file

@ -0,0 +1,12 @@
Index: contrib/texi2pod.pl
--- contrib/texi2pod.pl.orig
+++ contrib/texi2pod.pl
@@ -314,7 +314,7 @@ while(<$inf>) {
@columns = ();
for $column (split (/\s*\@tab\s*/, $1)) {
# @strong{...} is used a @headitem work-alike
- $column =~ s/^\@strong{(.*)}$/$1/;
+ $column =~ s/^\@strong\{(.*)\}$/$1/;
push @columns, $column;
}
$_ = "\n=item ".join (" : ", @columns)."\n";

View file

@ -0,0 +1,16 @@
fix for -fno-common
Index: gcc/config/avr32/avr32.c
--- gcc/config/avr32/avr32.c.orig
+++ gcc/config/avr32/avr32.c
@@ -207,10 +207,6 @@ static const struct arch_type_s avr32_arch_types[] = {
{NULL, 0, 0, 0, NULL}
};
-/* Default arch name */
-const char *avr32_arch_name = "none";
-const char *avr32_part_name = "none";
-
const struct part_type_s *avr32_part;
const struct arch_type_s *avr32_arch;

View file

@ -0,0 +1,23 @@
fix for -fno-common
Index: gcc/config/avr32/avr32.opt
--- gcc/config/avr32/avr32.opt.orig
+++ gcc/config/avr32/avr32.opt
@@ -56,7 +56,7 @@ Target Report Mask(HAS_ASM_ADDR_PSEUDOS)
Use assembler pseudo-instructions lda.w and call for handling direct addresses. (Enabled by default)
mpart=
-Target Report RejectNegative Joined Var(avr32_part_name)
+Target Report RejectNegative Joined Var(avr32_part_name) Init("none")
Specify the AVR32 part name
mcpu=
@@ -64,7 +64,7 @@ Target Report RejectNegative Joined Undocumented Var(a
Specify the AVR32 part name (deprecated)
march=
-Target Report RejectNegative Joined Var(avr32_arch_name)
+Target Report RejectNegative Joined Var(avr32_arch_name) Init("none")
Specify the AVR32 architecture name
mfast-float

View file

@ -0,0 +1,32 @@
Prevent 'permission denied' errors during build as non-root user
because of attempts to chown files to root.
These install targets are run during the build, before 'make fake'.
--- libgcc/Makefile.in.orig Fri Apr 10 01:23:07 2009
+++ libgcc/Makefile.in Mon Jan 6 16:24:11 2014
@@ -99,7 +99,7 @@ all: all-multi
# them back to the GCC directory. Too many things (other
# in-tree libraries, and DejaGNU) know about the layout
# of the build tree, for now.
- $(MAKE) install-leaf DESTDIR=$(gcc_objdir) \
+ $(MAKE) install-leaf INSTALL_DATA=cp DESTDIR=$(gcc_objdir) \
slibdir= libsubdir= MULTIOSDIR=$(MULTIDIR)
.PHONY: all-multi
@@ -857,7 +857,7 @@ endif
parts="$(EXTRA_PARTS)"; \
for file in $$parts; do \
rm -f $(gcc_objdir)$(MULTISUBDIR)/$$file; \
- $(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
+ cp $$file $(gcc_objdir)$(MULTISUBDIR)/; \
done
# Build extra startfiles in the gcc directory, for unconverted
@@ -890,7 +890,7 @@ gcc-extra-parts:
parts="$(GCC_EXTRA_PARTS)"; \
for file in $$parts; do \
rm -f $(gcc_objdir)$(MULTISUBDIR)/$$file; \
- $(INSTALL_DATA) $$file $(gcc_objdir)$(MULTISUBDIR)/; \
+ cp $$file $(gcc_objdir)$(MULTISUBDIR)/; \
done
all: $(extra-parts)

View file

@ -0,0 +1,16 @@
clang on powerpc64 defines vec_step already which collides with the
symbol in gcc, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239266#c23
renaming suggested at https://gcc.gnu.org/legacy-ml/gcc/2019-07/msg00131.html
Index: gcc/tree-vect-transform.c
--- gcc/tree-vect-transform.c.orig
+++ gcc/tree-vect-transform.c
@@ -46,6 +46,8 @@ along with GCC; see the file COPYING3. If not see
#include "toplev.h"
#include "real.h"
+#define vec_step vec_step_
+
/* Utility functions for the code transformation. */
static bool vect_transform_stmt (gimple, gimple_stmt_iterator *, bool *,
slp_tree, slp_instance);

View file

@ -0,0 +1,2 @@
This is a minimal boostrap cross-compiler to compile avr32-newlib.
It is needed to avoid a circular dependency while building avr32-gcc.

View file

@ -0,0 +1,111 @@
avr32/bootstrap/
avr32/bootstrap/avr32/
avr32/bootstrap/avr32/lib/
avr32/bootstrap/bin/
@bin avr32/bootstrap/bin/avr32-cpp
@bin avr32/bootstrap/bin/avr32-gcc
@bin avr32/bootstrap/bin/avr32-gcc-4.4.7
avr32/bootstrap/bin/avr32-gccbug
@bin avr32/bootstrap/bin/avr32-gcov
avr32/bootstrap/lib/
avr32/bootstrap/lib/gcc/
avr32/bootstrap/lib/gcc/avr32/
avr32/bootstrap/lib/gcc/avr32/4.4.7/
avr32/bootstrap/lib/gcc/avr32/4.4.7/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/
avr32/bootstrap/lib/gcc/avr32/4.4.7/include-fixed/
avr32/bootstrap/lib/gcc/avr32/4.4.7/include-fixed/README
avr32/bootstrap/lib/gcc/avr32/4.4.7/include-fixed/limits.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include-fixed/syslimits.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/float.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/iso646.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/stdarg.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/stdbool.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/stddef.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/stdfix.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/tgmath.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/unwind.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/include/varargs.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/fixinc_list
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/gsyslimits.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/include/
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/include/README
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/include/limits.h
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/macro_list
avr32/bootstrap/lib/gcc/avr32/4.4.7/install-tools/mkheaders.conf
avr32/bootstrap/lib/gcc/avr32/4.4.7/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/libgcov.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr1/libgcov.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2/libgcov.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr2nomul/libgcov.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3/libgcov.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crtbegin.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crtbeginS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crtend.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crtendS.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crti.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/crtn.o
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/libgcc.a
avr32/bootstrap/lib/gcc/avr32/4.4.7/ucr3fp/libgcov.a
avr32/bootstrap/lib/libiberty.a
avr32/bootstrap/libexec/
avr32/bootstrap/libexec/gcc/
avr32/bootstrap/libexec/gcc/avr32/
avr32/bootstrap/libexec/gcc/avr32/4.4.7/
@bin avr32/bootstrap/libexec/gcc/avr32/4.4.7/cc1
@bin avr32/bootstrap/libexec/gcc/avr32/4.4.7/collect2
avr32/bootstrap/libexec/gcc/avr32/4.4.7/install-tools/
avr32/bootstrap/libexec/gcc/avr32/4.4.7/install-tools/fixinc.sh
@bin avr32/bootstrap/libexec/gcc/avr32/4.4.7/install-tools/fixincl
avr32/bootstrap/libexec/gcc/avr32/4.4.7/install-tools/mkheaders
avr32/bootstrap/libexec/gcc/avr32/4.4.7/install-tools/mkinstalldirs
@comment @info info/cpp.info
@comment @info info/cppinternals.info
@comment @info info/gcc.info
@comment @info info/gccinstall.info
@comment @info info/gccint.info
@comment @man man/man1/avr32-cpp.1
@comment @man man/man1/avr32-gcc.1
@comment @man man/man1/avr32-gcov.1
@comment @man man/man7/fsf-funding.7
@comment @man man/man7/gfdl.7
@comment @man man/man7/gpl.7