SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
51
devel/arduino-esp8266/Makefile
Normal file
51
devel/arduino-esp8266/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
|||
COMMENT = esp8266 arduino core toolset
|
||||
V = 3.0.2
|
||||
DISTNAME = esp8266-${V}
|
||||
PKGNAME = arduino-${DISTNAME}
|
||||
REVISION = 2
|
||||
|
||||
CATEGORIES = devel
|
||||
|
||||
MAINTAINER = Tracey Emery <tracey@openbsd.org>
|
||||
|
||||
#LGPLv2.1, MIT, BSD, Zlib
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
MASTER_SITES = https://github.com/esp8266/Arduino/releases/download/${V}/
|
||||
EXTRACT_SUFX = .zip
|
||||
|
||||
MODULES = lang/python
|
||||
|
||||
BUILD_DEPENDS = devel/xtensa-lx106-elf/gcc \
|
||||
devel/xtensa-lx106-elf/lx106-hal \
|
||||
devel/xtensa-lx106-elf/newlib
|
||||
RUN_DEPENDS += devel/arduino \
|
||||
devel/mklittlefs \
|
||||
devel/mkspiffs \
|
||||
devel/py-esptool${MODPY_FLAVOR} \
|
||||
devel/xtensa-lx106-elf/binutils \
|
||||
devel/xtensa-lx106-elf/gcc \
|
||||
devel/xtensa-lx106-elf/lx106-hal \
|
||||
devel/xtensa-lx106-elf/newlib
|
||||
|
||||
INSTALLDIR = ${PREFIX}/share/arduino/hardware/espressif/esp8266
|
||||
|
||||
NO_TEST = Yes
|
||||
|
||||
pre-build:
|
||||
${SUBST_CMD} ${WRKDIST}/platform.txt
|
||||
|
||||
do-build:
|
||||
${MODPY_BIN} ${MODPY_LIBDIR}/compileall.py ${WRKSRC}
|
||||
|
||||
# libc is no longer supplied, so we need to get it from newlib
|
||||
# note, a symlink doesn't work here, and I don't know why
|
||||
do-install:
|
||||
@mkdir -p ${INSTALLDIR}
|
||||
@cp -r ${WRKDIST}/* ${INSTALLDIR}
|
||||
@cd ${INSTALLDIR}/tools/sdk && \
|
||||
${INSTALL_DATA_DIR} libc/xtensa-lx106-elf && \
|
||||
cp -r ${LOCALBASE}/xtensa-lx106-elf/xtensa-lx106-elf/include \
|
||||
libc/xtensa-lx106-elf/
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/arduino-esp8266/distinfo
Normal file
2
devel/arduino-esp8266/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (esp8266-3.0.2.zip) = ZTrdl98KhQ68JvEFNVvnSfuDwtt7Hd8+d5UOaUBZ65w=
|
||||
SIZE (esp8266-3.0.2.zip) = 38204730
|
|
@ -0,0 +1,15 @@
|
|||
Index: libraries/LittleFS/lib/littlefs/scripts/prefix.py
|
||||
--- libraries/LittleFS/lib/littlefs/scripts/prefix.py.orig
|
||||
+++ libraries/LittleFS/lib/littlefs/scripts/prefix.py
|
||||
@@ -52,9 +52,9 @@ def main(from_prefix, to_prefix=None, files=None):
|
||||
subprocess.check_call(['git', 'add', newname])
|
||||
|
||||
# Summary
|
||||
- print '%s: %d replacements' % (
|
||||
+ print('%s: %d replacements' % (
|
||||
'%s -> %s' % (oldname, newname) if namecount else oldname,
|
||||
- count)
|
||||
+ count))
|
||||
|
||||
if __name__ == "__main__":
|
||||
import sys
|
16
devel/arduino-esp8266/patches/patch-platform_txt
Normal file
16
devel/arduino-esp8266/patches/patch-platform_txt
Normal file
|
@ -0,0 +1,16 @@
|
|||
Index: platform.txt
|
||||
--- platform.txt.orig
|
||||
+++ platform.txt
|
||||
@@ -9,9 +9,9 @@ name=ESP8266 Boards (3.0.2)
|
||||
version=3.0.2
|
||||
|
||||
# These will be removed by the packager script when doing a JSON release
|
||||
-
|
||||
-
|
||||
-
|
||||
+runtime.tools.xtensa-lx106-elf-gcc.path=${LOCALBASE}/xtensa-lx106-elf
|
||||
+runtime.tools.python3.path=${LOCALBASE}/bin/
|
||||
+runtime.tools.esptool.path=${LOCALBASE}/bin
|
||||
|
||||
runtime.tools.signing={runtime.platform.path}/tools/signing.py
|
||||
runtime.tools.elf2bin={runtime.platform.path}/tools/elf2bin.py
|
6
devel/arduino-esp8266/pkg/DESCR
Normal file
6
devel/arduino-esp8266/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Framework to program Espressif ESP8266 chipsets via the Arduino environment.
|
||||
|
||||
Before using this arduino-core, the makeesparduino package must be installed
|
||||
to compile your sketches.
|
||||
|
||||
If you haven't already, please use pkg_add to install makeesparduino.
|
4146
devel/arduino-esp8266/pkg/PLIST
Normal file
4146
devel/arduino-esp8266/pkg/PLIST
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Add table
Add a link
Reference in a new issue