SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
28
devel/angr/py-pyvex/patches/patch-pyvex_c_Makefile
Normal file
28
devel/angr/py-pyvex/patches/patch-pyvex_c_Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
- Don't overwrite CFLAGS
|
||||
- Force use of shared libraries
|
||||
|
||||
Index: pyvex_c/Makefile
|
||||
--- pyvex_c/Makefile.orig
|
||||
+++ pyvex_c/Makefile
|
||||
@@ -33,18 +33,17 @@ sq = $(subst $(sp),?,$1)
|
||||
CC?=gcc
|
||||
AR=ar
|
||||
INCFLAGS=-I "$(VEX_INCLUDE_PATH)"
|
||||
-CFLAGS=-g -O2 -Wall -shared -fPIC -std=c99 $(INCFLAGS)
|
||||
|
||||
OBJECTS=pyvex.o logging.o analysis.o postprocess.o
|
||||
HEADERS=pyvex.h
|
||||
|
||||
-all: $(LIBRARY_FILE) $(STATIC_LIBRARY_FILE)
|
||||
+all: $(LIBRARY_FILE)
|
||||
|
||||
%.o: %.c
|
||||
$(CC) -c $(CFLAGS) $<
|
||||
|
||||
-$(LIBRARY_FILE): $(OBJECTS) $(HEADERS) $(call sq,$(VEX_LIB_PATH)/libvex.a)
|
||||
- $(CC) $(CFLAGS) -o $(LIBRARY_FILE) $(OBJECTS) "$(VEX_LIB_PATH)/libvex.a" $(LDFLAGS)
|
||||
+$(LIBRARY_FILE): $(OBJECTS) $(HEADERS)
|
||||
+ $(CC) $(CFLAGS) -o $(LIBRARY_FILE) $(OBJECTS) $(LDFLAGS)
|
||||
|
||||
$(STATIC_LIBRARY_FILE): $(OBJECTS) $(HEADERS) $(call sq,$(VEX_LIB_PATH)/libvex.a)
|
||||
$(AR) rcs $(STATIC_LIBRARY_FILE) $(OBJECTS)
|
Loading…
Add table
Add a link
Reference in a new issue