SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
27
databases/ruby-ldap/Makefile
Normal file
27
databases/ruby-ldap/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
COMMENT= Ruby interface to some common LDAP libraries
|
||||
|
||||
PKGNAME= ldap-0.9.20
|
||||
REVISION= 2
|
||||
DISTNAME= ruby-${PKGNAME}
|
||||
CATEGORIES= databases
|
||||
|
||||
MASTER_SITES0= https://github.com/bearded/ruby-ldap/commit/
|
||||
PATCHFILES= ruby-ldap-taint-fix{72a4a89b28a99560b018b78069b29632f362a7d0}.patch:0
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
HOMEPAGE= https://github.com/bearded/ruby-ldap
|
||||
|
||||
MAINTAINER= Jeremy Evans <jeremy@openbsd.org>
|
||||
|
||||
# BSD
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
MODULES= lang/ruby
|
||||
|
||||
WANTLIB= crypto pthread ssl ldap lber sasl2
|
||||
|
||||
LIB_DEPENDS= databases/openldap
|
||||
|
||||
CONFIGURE_STYLE= ruby gem ext
|
||||
|
||||
.include <bsd.port.mk>
|
4
databases/ruby-ldap/distinfo
Normal file
4
databases/ruby-ldap/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
SHA256 (ruby-ldap-0.9.20.gem) = LUj2d36gzWSYSnOtAjiyeGn4Ni4BmPIVSHByVOzTMqM=
|
||||
SHA256 (ruby-ldap-taint-fix.patch) = os0NA2gy8ey9rmNu9+gAIic5XTa8MUbUXiE1XcVo1mA=
|
||||
SIZE (ruby-ldap-0.9.20.gem) = 67072
|
||||
SIZE (ruby-ldap-taint-fix.patch) = 757
|
15
databases/ruby-ldap/patches/patch-conn_c
Normal file
15
databases/ruby-ldap/patches/patch-conn_c
Normal file
|
@ -0,0 +1,15 @@
|
|||
Avoid deprecation message in Ruby 3.1, allow building with Ruby 3.2.
|
||||
|
||||
Index: conn.c
|
||||
--- conn.c.orig
|
||||
+++ conn.c
|
||||
@@ -1855,7 +1855,8 @@ Init_ldap_conn ()
|
||||
{
|
||||
rb_ldap_sort_obj = Qnil;
|
||||
|
||||
- rb_cLDAP_Conn = rb_define_class_under (rb_mLDAP, "Conn", rb_cData);
|
||||
+ rb_cLDAP_Conn = rb_define_class_under (rb_mLDAP, "Conn", rb_cObject);
|
||||
+ rb_undef_alloc_func(rb_cLDAP_Conn);
|
||||
rb_define_attr (rb_cLDAP_Conn, "referrals", 1, 0);
|
||||
rb_define_attr (rb_cLDAP_Conn, "controls", 1, 0);
|
||||
rb_define_attr (rb_cLDAP_Conn, "sasl_quiet", 1, 1);
|
10
databases/ruby-ldap/patches/patch-test_add2_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_add2_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/add2.rb.orig Wed Dec 20 13:31:07 2006
|
||||
+++ test/add2.rb Wed Dec 20 13:31:16 2006
|
||||
@@ -6,6 +6,7 @@ require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option( LDAP::LDAP_OPT_PROTOCOL_VERSION, 3 )
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','secret'){
|
||||
conn.perror("bind")
|
||||
entry1 = {
|
10
databases/ruby-ldap/patches/patch-test_add3_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_add3_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/add3.rb.orig Wed Dec 20 13:31:43 2006
|
||||
+++ test/add3.rb Wed Dec 20 13:32:00 2006
|
||||
@@ -8,6 +8,7 @@ require "./ldap"
|
||||
$KCODE = "UTF8"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','secret'){
|
||||
conn.perror("bind")
|
||||
entry1 = {
|
10
databases/ruby-ldap/patches/patch-test_add_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_add_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/add.rb.orig Wed Dec 20 13:18:24 2006
|
||||
+++ test/add.rb Wed Dec 20 13:29:39 2006
|
||||
@@ -6,6 +6,7 @@ require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option( LDAP::LDAP_OPT_PROTOCOL_VERSION, 3 )
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','secret'){
|
||||
conn.perror("bind")
|
||||
entry1 = [
|
11
databases/ruby-ldap/patches/patch-test_bind_rb
Normal file
11
databases/ruby-ldap/patches/patch-test_bind_rb
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- test/bind.rb.orig Wed Dec 20 13:16:25 2006
|
||||
+++ test/bind.rb Wed Dec 20 13:17:27 2006
|
||||
@@ -28,6 +28,8 @@ begin
|
||||
conn.bind
|
||||
rescue LDAP::InvalidDataError
|
||||
$ok = true
|
||||
+rescue LDAP::ResultError
|
||||
+ $ok = true
|
||||
end
|
||||
if( ! $ok )
|
||||
raise(RuntimeError, "multiple bind calls")
|
13
databases/ruby-ldap/patches/patch-test_compare_rb
Normal file
13
databases/ruby-ldap/patches/patch-test_compare_rb
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- test/compare.rb.orig Wed Dec 20 13:37:14 2006
|
||||
+++ test/compare.rb Wed Dec 20 13:37:26 2006
|
||||
@@ -5,7 +5,9 @@ $test = File.dirname($0)
|
||||
require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
-LDAP::Conn.new($HOST, $PORT).bind{|conn|
|
||||
+conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
+conn.bind{|conn|
|
||||
conn.perror("bind")
|
||||
begin
|
||||
conn.compare("cn=Takaaki Tateishi, dc=localhost, dc=localdomain",
|
10
databases/ruby-ldap/patches/patch-test_delete_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_delete_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/delete.rb.orig Wed Dec 20 13:36:50 2006
|
||||
+++ test/delete.rb Wed Dec 20 13:37:00 2006
|
||||
@@ -6,6 +6,7 @@ require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','secret'){
|
||||
conn.perror("bind")
|
||||
conn.delete("cn=Takaaki-Tateishi, dc=localhost, dc=localdomain")
|
10
databases/ruby-ldap/patches/patch-test_ext_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_ext_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/ext.rb.orig Wed Dec 20 13:37:36 2006
|
||||
+++ test/ext.rb Wed Dec 20 13:37:42 2006
|
||||
@@ -6,6 +6,7 @@ require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','secret'){
|
||||
conn.perror("bind")
|
||||
begin
|
10
databases/ruby-ldap/patches/patch-test_misc1_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_misc1_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/misc1.rb.orig Wed Dec 20 13:37:51 2006
|
||||
+++ test/misc1.rb Wed Dec 20 13:38:19 2006
|
||||
@@ -35,6 +35,7 @@ def delete_ou(agency)
|
||||
end
|
||||
|
||||
@ldap_conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+@ldap_conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
|
||||
p LDAP::VERSION
|
||||
begin
|
10
databases/ruby-ldap/patches/patch-test_misc2_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_misc2_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/misc2.rb.orig Wed Dec 20 13:38:26 2006
|
||||
+++ test/misc2.rb Wed Dec 20 13:38:36 2006
|
||||
@@ -29,6 +29,7 @@ def delete_ou(agency)
|
||||
end
|
||||
|
||||
@ldap_conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+@ldap_conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
@ldap_conn.bind("cn=root, dc=localhost, dc=localdomain", 'secret')
|
||||
|
||||
p LDAP::VERSION
|
10
databases/ruby-ldap/patches/patch-test_modrdn_rb
Normal file
10
databases/ruby-ldap/patches/patch-test_modrdn_rb
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- test/modrdn.rb.orig Wed Dec 20 13:35:43 2006
|
||||
+++ test/modrdn.rb Wed Dec 20 13:35:51 2006
|
||||
@@ -6,6 +6,7 @@ require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
|
||||
begin
|
||||
conn.bind('cn=root, dc=localhost, dc=localdomain','seret')
|
13
databases/ruby-ldap/patches/patch-test_search2_rb
Normal file
13
databases/ruby-ldap/patches/patch-test_search2_rb
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- test/search2.rb.orig Wed Dec 20 13:34:05 2006
|
||||
+++ test/search2.rb Wed Dec 20 13:34:35 2006
|
||||
@@ -10,7 +10,9 @@ sorter = proc{|s1,s2|
|
||||
s1<=>s2
|
||||
}
|
||||
|
||||
-LDAP::Conn.new($HOST, $PORT).bind{|conn|
|
||||
+conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
+conn.bind{|conn|
|
||||
conn.perror("bind")
|
||||
sub = nil
|
||||
conn.search("dc=localhost, dc=localdomain", LDAP::LDAP_SCOPE_SUBTREE,
|
13
databases/ruby-ldap/patches/patch-test_search3_rb
Normal file
13
databases/ruby-ldap/patches/patch-test_search3_rb
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- test/search3.rb.orig Wed Dec 20 13:34:41 2006
|
||||
+++ test/search3.rb Wed Dec 20 13:34:59 2006
|
||||
@@ -8,8 +8,9 @@ require "./ldap"
|
||||
$KCODE = "UTF8"
|
||||
|
||||
conn = LDAP::Conn.new($HOST, $PORT)
|
||||
-conn.perror("bind")
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
conn.bind{
|
||||
+ conn.perror("bind")
|
||||
# search2 returns an array of hash
|
||||
print("search2 without a block:\n")
|
||||
conn.search2("dc=localhost, dc=localdomain", LDAP::LDAP_SCOPE_SUBTREE,
|
14
databases/ruby-ldap/patches/patch-test_search_rb
Normal file
14
databases/ruby-ldap/patches/patch-test_search_rb
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- test/search.rb.orig Wed Dec 20 13:32:50 2006
|
||||
+++ test/search.rb Wed Dec 20 13:33:24 2006
|
||||
@@ -5,7 +5,10 @@ $test = File.dirname($0)
|
||||
require "#{$test}/conf"
|
||||
require "./ldap"
|
||||
|
||||
-LDAP::Conn.new($HOST, $PORT).bind{|conn|
|
||||
+conn = LDAP::Conn.new($HOST, $PORT)
|
||||
+conn.set_option(LDAP::LDAP_OPT_PROTOCOL_VERSION, 3)
|
||||
+conn.bind{|conn|
|
||||
+
|
||||
conn.perror("bind")
|
||||
begin
|
||||
conn.search("dc=localhost, dc=localdomain",
|
4
databases/ruby-ldap/pkg/DESCR
Normal file
4
databases/ruby-ldap/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Ruby/LDAP is an extension library for Ruby. It provides the interface
|
||||
to some LDAP libraries (e.g. OpenLDAP, UMich LDAP, Netscape SDK,
|
||||
ActiveDirectory). The common API for application development is
|
||||
described in RFC1823 and is supported by Ruby/LDAP.
|
42
databases/ruby-ldap/pkg/PLIST
Normal file
42
databases/ruby-ldap/pkg/PLIST
Normal file
|
@ -0,0 +1,42 @@
|
|||
${GEM_LIB}/cache/${DISTNAME}.gem
|
||||
${GEM_LIB}/gems/${DISTNAME}/
|
||||
${GEM_LIB}/gems/${DISTNAME}/COPYING
|
||||
${GEM_LIB}/gems/${DISTNAME}/ChangeLog
|
||||
${GEM_LIB}/gems/${DISTNAME}/FAQ
|
||||
${GEM_LIB}/gems/${DISTNAME}/Makefile
|
||||
${GEM_LIB}/gems/${DISTNAME}/NOTES
|
||||
${GEM_LIB}/gems/${DISTNAME}/README
|
||||
${GEM_LIB}/gems/${DISTNAME}/TODO
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/ldap/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/ldap.so
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/ldap/control.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/ldap/ldif.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/ldap/schema.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/add.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/add2.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/add3.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/bind-ldaps.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/bind-sasl.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/bind-ssl.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/bind.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/compare.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/conf.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/delete.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/ext.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/misc1.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/misc2.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/modrdn.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/moz_cert.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/search.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/search2.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/search3.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/setup.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/subschema.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/tc_conn.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/tc_ldif.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/tc_schema.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/tc_search.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/ts_ldap.rb
|
||||
${GEM_LIB}/specifications/${DISTNAME}.gemspec
|
Loading…
Add table
Add a link
Reference in a new issue