SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
22
databases/py-carbon/patches/patch-setup_py
Normal file
22
databases/py-carbon/patches/patch-setup_py
Normal file
|
@ -0,0 +1,22 @@
|
|||
Index: setup.py
|
||||
--- setup.py.orig
|
||||
+++ setup.py
|
||||
@@ -61,16 +61,15 @@ else:
|
||||
storage_dirs = [ ('storage/ceres/dummy.txt', []), ('storage/whisper/dummy.txt',[]),
|
||||
('storage/lists',[]), ('storage/log/dummy.txt',[]),
|
||||
('storage/rrd/dummy.txt',[]) ]
|
||||
-conf_files = [ ('conf', glob('conf/*.example')) ]
|
||||
+conf_files = [ ('${GRAPHITE_EGDIR}', glob('conf/*.example')) ]
|
||||
|
||||
-install_files = storage_dirs + conf_files
|
||||
+install_files = conf_files
|
||||
|
||||
# Let's include redhat init scripts, despite build platform
|
||||
# but won't put them in /etc/init.d/ automatically anymore
|
||||
init_scripts = [ ('examples/init.d', ['distro/redhat/init.d/carbon-cache',
|
||||
'distro/redhat/init.d/carbon-relay',
|
||||
'distro/redhat/init.d/carbon-aggregator']) ]
|
||||
-install_files += init_scripts
|
||||
|
||||
def read(fname):
|
||||
with open(os.path.join(os.path.dirname(__file__), fname)) as f:
|
Loading…
Add table
Add a link
Reference in a new issue