SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
30
databases/mariadb/patches/patch-scripts_CMakeLists_txt
Normal file
30
databases/mariadb/patches/patch-scripts_CMakeLists_txt
Normal file
|
@ -0,0 +1,30 @@
|
|||
Index: scripts/CMakeLists.txt
|
||||
--- scripts/CMakeLists.txt.orig
|
||||
+++ scripts/CMakeLists.txt
|
||||
@@ -186,25 +186,14 @@ ENDIF(UNIX)
|
||||
# i.e. makes access relative the current directory. This matches
|
||||
# the documentation, so better not change this.
|
||||
|
||||
-IF(INSTALL_LAYOUT MATCHES "STANDALONE")
|
||||
- SET(prefix ".")
|
||||
+ SET(prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
SET(bindir ${prefix}/${INSTALL_BINDIR})
|
||||
SET(sbindir ${prefix}/${INSTALL_SBINDIR})
|
||||
SET(scriptdir ${prefix}/${INSTALL_BINDIR})
|
||||
SET(libexecdir ${prefix}/${INSTALL_SBINDIR})
|
||||
SET(pkgdatadir ${prefix}/${INSTALL_MYSQLSHAREDIR})
|
||||
SET(pkgplugindir ${prefix}/${INSTALL_PLUGINDIR})
|
||||
- SET(localstatedir ${prefix}/data)
|
||||
-ELSE()
|
||||
- SET(prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
- SET(bindir ${INSTALL_BINDIRABS})
|
||||
- SET(sbindir ${INSTALL_SBINDIRABS})
|
||||
- SET(scriptdir ${INSTALL_BINDIRABS})
|
||||
- SET(libexecdir ${INSTALL_SBINDIRABS})
|
||||
- SET(pkgdatadir ${INSTALL_MYSQLSHAREDIRABS})
|
||||
- SET(pkgplugindir ${INSTALL_PLUGINDIRABS})
|
||||
SET(localstatedir ${MYSQL_DATADIR})
|
||||
-ENDIF()
|
||||
|
||||
SET(resolveip_locations "$basedir/${INSTALL_BINDIR} $basedir/bin")
|
||||
SET(mysqld_locations "$basedir/${INSTALL_SBINDIR} $basedir/libexec $basedir/sbin $basedir/bin")
|
Loading…
Add table
Add a link
Reference in a new issue