SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
30
audio/pulseaudio/patches/patch-src_modules_meson_build
Normal file
30
audio/pulseaudio/patches/patch-src_modules_meson_build
Normal file
|
@ -0,0 +1,30 @@
|
|||
2nd chunk:
|
||||
Should match b_lundef in meson(1).
|
||||
|
||||
Index: src/modules/meson.build
|
||||
--- src/modules/meson.build.orig
|
||||
+++ src/modules/meson.build
|
||||
@@ -100,6 +100,14 @@ if cc.has_function('mkfifo')
|
||||
]
|
||||
endif
|
||||
|
||||
+# sndio(7)
|
||||
+if host_machine.system() == 'openbsd'
|
||||
+ libsndio_dep = dependency('sndio', required: true)
|
||||
+ all_modules += [
|
||||
+ [ 'module-sndio', 'module-sndio.c', [], [], [libsndio_dep], [] ],
|
||||
+ ]
|
||||
+endif
|
||||
+
|
||||
# Modules enabled by dependencies
|
||||
|
||||
if alsa_dep.found()
|
||||
@@ -310,7 +318,7 @@ foreach m : all_modules
|
||||
install_rpath : rpath_dirs,
|
||||
install_dir : modlibexecdir,
|
||||
dependencies : [thread_dep, libpulse_dep, libpulsecommon_dep, libpulsecore_dep, libintl_dep, platform_dep, platform_socket_dep] + extra_deps,
|
||||
- link_args : [nodelete_link_args, '-Wl,--no-undefined' ],
|
||||
+ link_args : [nodelete_link_args],
|
||||
link_with : extra_libs,
|
||||
name_prefix : '',
|
||||
implicit_include_directories : false)
|
Loading…
Add table
Add a link
Reference in a new issue