SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,19 @@
Index: configure.ac
--- configure.ac.orig
+++ configure.ac
@@ -147,6 +147,15 @@ if test x"$enable_oss" != x"no"; then
esac
fi
+dnl check for sndio
+AC_ARG_ENABLE([sndio],
+ [ --disable-sndio make a version not using sndio])
+if test x"$enable_sndio" != x"no"; then
+ AC_DEFINE([LIBAO_SNDIO],,[libao sndio support])
+ AC_CHECK_LIB([sndio],[sio_initpar],
+ [LIBAO_LIBS="$LIBAO_LIBS -lsndio"])
+fi
+
dnl check for solaris
AC_ARG_ENABLE([solaris-audio],
[ --disable-solaris-audio make a version not using solaris audio])