UPDATE: devel/cmake 3.28.3 -> 3.30.1
This commit is contained in:
parent
f260267c10
commit
294b0e463d
17 changed files with 170 additions and 4149 deletions
|
@ -2,11 +2,10 @@ DPB_PROPERTIES = parallel
|
||||||
|
|
||||||
COMMENT = portable build system
|
COMMENT = portable build system
|
||||||
|
|
||||||
VER = 3.28.3
|
VER = 3.30.1
|
||||||
EPOCH = 1
|
EPOCH = 1
|
||||||
DISTNAME = cmake-${VER}
|
DISTNAME = cmake-${VER}
|
||||||
CATEGORIES = devel
|
CATEGORIES = devel
|
||||||
REVISION = 0
|
|
||||||
|
|
||||||
HOMEPAGE = https://www.cmake.org/
|
HOMEPAGE = https://www.cmake.org/
|
||||||
|
|
||||||
|
@ -17,8 +16,9 @@ SITES = https://www.cmake.org/files/v${VER:R}/
|
||||||
# BSD
|
# BSD
|
||||||
PERMIT_PACKAGE = Yes
|
PERMIT_PACKAGE = Yes
|
||||||
|
|
||||||
WANTLIB += ${COMPILER_LIBCXX} archive c curl curses execinfo expat form
|
WANTLIB += ${COMPILER_LIBCXX} archive c curl curses expat form
|
||||||
WANTLIB += jsoncpp m rhash uv z
|
WANTLIB += jsoncpp m rhash uv z
|
||||||
|
WANTLIB += execinfo
|
||||||
|
|
||||||
COMPILER = base-clang ports-gcc
|
COMPILER = base-clang ports-gcc
|
||||||
|
|
||||||
|
@ -41,10 +41,8 @@ CONFIGURE_ARGS = --datadir=share/cmake \
|
||||||
--no-qt-gui \
|
--no-qt-gui \
|
||||||
--parallel=${MAKE_JOBS} \
|
--parallel=${MAKE_JOBS} \
|
||||||
--prefix=${PREFIX} \
|
--prefix=${PREFIX} \
|
||||||
--sphinx-html \
|
|
||||||
--system-libs \
|
--system-libs \
|
||||||
--no-system-cppdap \
|
--no-system-cppdap \
|
||||||
--sphinx-man \
|
|
||||||
--verbose
|
--verbose
|
||||||
|
|
||||||
CONFIGURE_ENV += MAKE=${MAKE_PROGRAM}
|
CONFIGURE_ENV += MAKE=${MAKE_PROGRAM}
|
||||||
|
|
|
@ -13,6 +13,10 @@ CONFIGURE_ENV += MODCMAKE_USE_SHARED_LIBS=yes
|
||||||
MAKE_ENV += MODCMAKE_USE_SHARED_LIBS=yes
|
MAKE_ENV += MODCMAKE_USE_SHARED_LIBS=yes
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
|
# Limit the number of moc/uic processes started by cmake_autogen
|
||||||
|
# (default: number of CPUs on the system)
|
||||||
|
CONFIGURE_ARGS += -DCMAKE_AUTOGEN_PARALLEL=${MAKE_JOBS}
|
||||||
|
|
||||||
USE_NINJA ?= Yes
|
USE_NINJA ?= Yes
|
||||||
|
|
||||||
.if ${USE_NINJA:L} == "yes"
|
.if ${USE_NINJA:L} == "yes"
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (cmake-3.28.3.tar.gz) = crdXDlyFk95qxKtDO3PqsYxfsyiIBGDIbOMmCBQa1cE=
|
SHA256 (cmake-3.30.1.tar.gz) = 35s8U+POhMPBt8JT5c7/fY0fCE/wZz0EjyYOBMyzRuE=
|
||||||
SIZE (cmake-3.28.3.tar.gz) = 11067653
|
SIZE (cmake-3.30.1.tar.gz) = 11500521
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
Index: Modules/Compiler/GNU-Fortran.cmake
|
|
||||||
--- Modules/Compiler/GNU-Fortran.cmake.orig
|
|
||||||
+++ Modules/Compiler/GNU-Fortran.cmake
|
|
||||||
@@ -17,9 +17,11 @@ endif()
|
|
||||||
|
|
||||||
set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpreprocessed")
|
|
||||||
|
|
||||||
-# No -DNDEBUG for Fortran.
|
|
||||||
-string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
|
||||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
|
||||||
+if(NOT DEFINED ENV{MODCMAKE_PORT_BUILD})
|
|
||||||
+ # No -DNDEBUG for Fortran.
|
|
||||||
+ string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
|
||||||
+ string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
|
||||||
+endif()
|
|
||||||
|
|
||||||
# No -isystem for Fortran because it will not find .mod files.
|
|
||||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
|
|
@ -1,25 +1,28 @@
|
||||||
Index: Modules/Compiler/GNU.cmake
|
Index: Modules/Compiler/GNU.cmake
|
||||||
--- Modules/Compiler/GNU.cmake.orig
|
--- Modules/Compiler/GNU.cmake.orig
|
||||||
+++ Modules/Compiler/GNU.cmake
|
+++ Modules/Compiler/GNU.cmake
|
||||||
@@ -100,10 +100,17 @@ macro(__compiler_gnu lang)
|
@@ -107,11 +107,19 @@ macro(__compiler_gnu lang)
|
||||||
|
endif()
|
||||||
|
|
||||||
# Initial configuration flags.
|
# Initial configuration flags.
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
- string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
- string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
- string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
- string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
- string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os")
|
||||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG")
|
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3")
|
||||||
- string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
- string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
+ if(DEFINED ENV{MODCMAKE_PORT_BUILD})
|
+ if(DEFINED ENV{MODCMAKE_PORT_BUILD})
|
||||||
|
+ string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
+ string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " ")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " ")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g")
|
||||||
+ else()
|
+ else()
|
||||||
|
+ string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
+ string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3")
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
+ endif()
|
+ endif()
|
||||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
if(NOT "x${lang}" STREQUAL "xFortran")
|
||||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -DNDEBUG")
|
||||||
if(NOT APPLE OR NOT CMAKE_${lang}_COMPILER_VERSION VERSION_LESS 4) # work around #4462
|
string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -DNDEBUG")
|
||||||
|
|
|
@ -3,7 +3,7 @@ Add libs and paths. Ensure the lib is used for the C case.
|
||||||
Index: Modules/FindOpenMP.cmake
|
Index: Modules/FindOpenMP.cmake
|
||||||
--- Modules/FindOpenMP.cmake.orig
|
--- Modules/FindOpenMP.cmake.orig
|
||||||
+++ Modules/FindOpenMP.cmake
|
+++ Modules/FindOpenMP.cmake
|
||||||
@@ -101,9 +101,9 @@ function(_OPENMP_FLAG_CANDIDATES LANG)
|
@@ -116,9 +116,9 @@ function(_OPENMP_FLAG_CANDIDATES LANG)
|
||||||
if(NOT OpenMP_${LANG}_FLAG)
|
if(NOT OpenMP_${LANG}_FLAG)
|
||||||
unset(OpenMP_FLAG_CANDIDATES)
|
unset(OpenMP_FLAG_CANDIDATES)
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Modules/FindSDL.cmake
|
Index: Modules/FindSDL.cmake
|
||||||
--- Modules/FindSDL.cmake.orig
|
--- Modules/FindSDL.cmake.orig
|
||||||
+++ Modules/FindSDL.cmake
|
+++ Modules/FindSDL.cmake
|
||||||
@@ -124,6 +124,11 @@ else()
|
@@ -127,6 +127,11 @@ else()
|
||||||
set(VC_LIB_PATH_SUFFIX lib/x86)
|
set(VC_LIB_PATH_SUFFIX lib/x86)
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
|
|
34
devel/cmake/patches/patch-Modules_FindTIFF_cmake
Normal file
34
devel/cmake/patches/patch-Modules_FindTIFF_cmake
Normal file
|
@ -0,0 +1,34 @@
|
||||||
|
Revert: https://gitlab.kitware.com/cmake/cmake/-/merge_requests/9300
|
||||||
|
More: https://gitlab.kitware.com/cmake/cmake/-/issues/26038
|
||||||
|
Index: Modules/FindTIFF.cmake
|
||||||
|
--- Modules/FindTIFF.cmake.orig
|
||||||
|
+++ Modules/FindTIFF.cmake
|
||||||
|
@@ -101,9 +101,9 @@ if (_TIFF_component_opt)
|
||||||
|
endif ()
|
||||||
|
unset(_TIFF_component_opt)
|
||||||
|
# Always find with QUIET to avoid noise when it is not found.
|
||||||
|
-find_package(Tiff CONFIG QUIET ${_TIFF_args})
|
||||||
|
+find_package(tiff CONFIG QUIET ${_TIFF_args})
|
||||||
|
unset(_TIFF_args)
|
||||||
|
-if (Tiff_FOUND)
|
||||||
|
+if (tiff_FOUND)
|
||||||
|
if (NOT TARGET TIFF::TIFF)
|
||||||
|
add_library(TIFF::TIFF IMPORTED INTERFACE)
|
||||||
|
set_target_properties(TIFF::TIFF PROPERTIES
|
||||||
|
@@ -202,7 +202,7 @@ if (Tiff_FOUND)
|
||||||
|
endif ()
|
||||||
|
endif ()
|
||||||
|
endif ()
|
||||||
|
- set(TIFF_VERSION_STRING "${Tiff_VERSION}")
|
||||||
|
+ set(TIFF_VERSION_STRING "${tiff_VERSION}")
|
||||||
|
foreach (_TIFF_component IN LISTS TIFF_FIND_COMPONENTS)
|
||||||
|
set(TIFF_${_TIFF_component}_FOUND "${Tiff_${_TIFF_component}_FOUND}")
|
||||||
|
endforeach ()
|
||||||
|
@@ -211,7 +211,6 @@ if (Tiff_FOUND)
|
||||||
|
include(${CMAKE_CURRENT_LIST_DIR}/FindPackageHandleStandardArgs.cmake)
|
||||||
|
find_package_handle_standard_args(TIFF
|
||||||
|
HANDLE_COMPONENTS
|
||||||
|
- REQUIRED_VARS Tiff_DIR
|
||||||
|
VERSION_VAR TIFF_VERSION_STRING)
|
||||||
|
|
||||||
|
cmake_policy(POP)
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Source/cmFileCommand.cxx
|
Index: Source/cmFileCommand.cxx
|
||||||
--- Source/cmFileCommand.cxx.orig
|
--- Source/cmFileCommand.cxx.orig
|
||||||
+++ Source/cmFileCommand.cxx
|
+++ Source/cmFileCommand.cxx
|
||||||
@@ -1816,6 +1816,13 @@ bool HandleDownloadCommand(std::vector<std::string> co
|
@@ -1870,6 +1870,13 @@ bool HandleDownloadCommand(std::vector<std::string> co
|
||||||
++i;
|
++i;
|
||||||
std::string file;
|
std::string file;
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ Index: Source/cmFileCommand.cxx
|
||||||
long timeout = 0;
|
long timeout = 0;
|
||||||
long inactivity_timeout = 0;
|
long inactivity_timeout = 0;
|
||||||
std::string logVar;
|
std::string logVar;
|
||||||
@@ -2226,6 +2233,12 @@ bool HandleUploadCommand(std::vector<std::string> cons
|
@@ -2327,6 +2334,12 @@ bool HandleUploadCommand(std::vector<std::string> cons
|
||||||
cmExecutionStatus& status)
|
cmExecutionStatus& status)
|
||||||
{
|
{
|
||||||
#if !defined(CMAKE_BOOTSTRAP)
|
#if !defined(CMAKE_BOOTSTRAP)
|
||||||
|
|
|
@ -3,7 +3,7 @@ Disable find_package QUIET option in openbsd ports builds.
|
||||||
Index: Source/cmFindPackageCommand.cxx
|
Index: Source/cmFindPackageCommand.cxx
|
||||||
--- Source/cmFindPackageCommand.cxx.orig
|
--- Source/cmFindPackageCommand.cxx.orig
|
||||||
+++ Source/cmFindPackageCommand.cxx
|
+++ Source/cmFindPackageCommand.cxx
|
||||||
@@ -711,7 +711,13 @@ bool cmFindPackageCommand::InitialPass(std::vector<std
|
@@ -712,7 +712,13 @@ bool cmFindPackageCommand::InitialPass(std::vector<std
|
||||||
std::vector<std::size_t> moduleArgs;
|
std::vector<std::size_t> moduleArgs;
|
||||||
for (std::size_t i = 1u; i < args.size(); ++i) {
|
for (std::size_t i = 1u; i < args.size(); ++i) {
|
||||||
if (args[i] == "QUIET") {
|
if (args[i] == "QUIET") {
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Source/cmGeneratorTarget.cxx
|
Index: Source/cmGeneratorTarget.cxx
|
||||||
--- Source/cmGeneratorTarget.cxx.orig
|
--- Source/cmGeneratorTarget.cxx.orig
|
||||||
+++ Source/cmGeneratorTarget.cxx
|
+++ Source/cmGeneratorTarget.cxx
|
||||||
@@ -5269,6 +5269,50 @@ cmGeneratorTarget::Names cmGeneratorTarget::GetLibrary
|
@@ -2963,6 +2963,50 @@ cmGeneratorTarget::Names cmGeneratorTarget::GetLibrary
|
||||||
targetNames.Output =
|
targetNames.Output =
|
||||||
cmStrCat(components.prefix, targetNames.Base, components.suffix);
|
cmStrCat(components.prefix, targetNames.Base, components.suffix);
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Source/cmGlobalGenerator.cxx
|
Index: Source/cmGlobalGenerator.cxx
|
||||||
--- Source/cmGlobalGenerator.cxx.orig
|
--- Source/cmGlobalGenerator.cxx.orig
|
||||||
+++ Source/cmGlobalGenerator.cxx
|
+++ Source/cmGlobalGenerator.cxx
|
||||||
@@ -2861,6 +2861,9 @@ void cmGlobalGenerator::AddGlobalTarget_Test(
|
@@ -2898,6 +2898,9 @@ void cmGlobalGenerator::AddGlobalTarget_Test(
|
||||||
cmCustomCommandLine singleLine;
|
cmCustomCommandLine singleLine;
|
||||||
singleLine.push_back(cmSystemTools::GetCTestCommand());
|
singleLine.push_back(cmSystemTools::GetCTestCommand());
|
||||||
singleLine.push_back("--force-new-ctest-process");
|
singleLine.push_back("--force-new-ctest-process");
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Source/cmInstallCommand.cxx
|
Index: Source/cmInstallCommand.cxx
|
||||||
--- Source/cmInstallCommand.cxx.orig
|
--- Source/cmInstallCommand.cxx.orig
|
||||||
+++ Source/cmInstallCommand.cxx
|
+++ Source/cmInstallCommand.cxx
|
||||||
@@ -658,6 +658,9 @@ bool HandleTargetsMode(std::vector<std::string> const&
|
@@ -659,6 +659,9 @@ bool HandleTargetsMode(std::vector<std::string> const&
|
||||||
}
|
}
|
||||||
|
|
||||||
// Select the mode for installing symlinks to versioned shared libraries.
|
// Select the mode for installing symlinks to versioned shared libraries.
|
||||||
|
@ -11,7 +11,7 @@ Index: Source/cmInstallCommand.cxx
|
||||||
cmInstallTargetGenerator::NamelinkModeType namelinkMode =
|
cmInstallTargetGenerator::NamelinkModeType namelinkMode =
|
||||||
cmInstallTargetGenerator::NamelinkModeNone;
|
cmInstallTargetGenerator::NamelinkModeNone;
|
||||||
if (libraryArgs.GetNamelinkOnly()) {
|
if (libraryArgs.GetNamelinkOnly()) {
|
||||||
@@ -673,6 +676,12 @@ bool HandleTargetsMode(std::vector<std::string> const&
|
@@ -674,6 +677,12 @@ bool HandleTargetsMode(std::vector<std::string> const&
|
||||||
} else if (archiveArgs.GetNamelinkSkip()) {
|
} else if (archiveArgs.GetNamelinkSkip()) {
|
||||||
importlinkMode = cmInstallTargetGenerator::NamelinkModeSkip;
|
importlinkMode = cmInstallTargetGenerator::NamelinkModeSkip;
|
||||||
}
|
}
|
||||||
|
|
|
@ -13,7 +13,7 @@ why it's failing. Upstream bug report [2]
|
||||||
Index: Source/cmQtAutoGenInitializer.cxx
|
Index: Source/cmQtAutoGenInitializer.cxx
|
||||||
--- Source/cmQtAutoGenInitializer.cxx.orig
|
--- Source/cmQtAutoGenInitializer.cxx.orig
|
||||||
+++ Source/cmQtAutoGenInitializer.cxx
|
+++ Source/cmQtAutoGenInitializer.cxx
|
||||||
@@ -1809,6 +1809,10 @@ bool cmQtAutoGenInitializer::SetupWriteAutogenInfo()
|
@@ -1971,6 +1971,10 @@ bool cmQtAutoGenInitializer::SetupWriteAutogenInfo()
|
||||||
if (this->Moc.PredefsCmd.size() >= 3) {
|
if (this->Moc.PredefsCmd.size() >= 3) {
|
||||||
this->Moc.PredefsCmd.insert(this->Moc.PredefsCmd.begin() + 1,
|
this->Moc.PredefsCmd.insert(this->Moc.PredefsCmd.begin() + 1,
|
||||||
CompileOptionValue);
|
CompileOptionValue);
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: Source/cmTarget.cxx
|
Index: Source/cmTarget.cxx
|
||||||
--- Source/cmTarget.cxx.orig
|
--- Source/cmTarget.cxx.orig
|
||||||
+++ Source/cmTarget.cxx
|
+++ Source/cmTarget.cxx
|
||||||
@@ -477,7 +477,7 @@ TargetProperty const StaticTargetProperties[] = {
|
@@ -483,7 +483,7 @@ TargetProperty const StaticTargetProperties[] = {
|
||||||
{ "INSTALL_NAME_DIR"_s, IC::CanCompileSources },
|
{ "INSTALL_NAME_DIR"_s, IC::CanCompileSources },
|
||||||
{ "INSTALL_REMOVE_ENVIRONMENT_RPATH"_s, IC::CanCompileSources },
|
{ "INSTALL_REMOVE_ENVIRONMENT_RPATH"_s, IC::CanCompileSources },
|
||||||
{ "INSTALL_RPATH"_s, ""_s, IC::CanCompileSources },
|
{ "INSTALL_RPATH"_s, ""_s, IC::CanCompileSources },
|
||||||
|
|
|
@ -4,7 +4,7 @@ on ports-gcc arches.
|
||||||
Index: Source/kwsys/CMakeLists.txt
|
Index: Source/kwsys/CMakeLists.txt
|
||||||
--- Source/kwsys/CMakeLists.txt.orig
|
--- Source/kwsys/CMakeLists.txt.orig
|
||||||
+++ Source/kwsys/CMakeLists.txt
|
+++ Source/kwsys/CMakeLists.txt
|
||||||
@@ -515,7 +515,7 @@ if(KWSYS_USE_SystemInformation)
|
@@ -507,7 +507,7 @@ if(KWSYS_USE_SystemInformation)
|
||||||
set_property(SOURCE SystemInformation.cxx APPEND PROPERTY
|
set_property(SOURCE SystemInformation.cxx APPEND PROPERTY
|
||||||
COMPILE_DEFINITIONS KWSYS_CXX_HAS_RLIMIT64=1)
|
COMPILE_DEFINITIONS KWSYS_CXX_HAS_RLIMIT64=1)
|
||||||
endif()
|
endif()
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Add table
Add a link
Reference in a new issue