sync ports with The Matrix
This commit is contained in:
parent
4cc27cb2e4
commit
130329df10
773 changed files with 5162 additions and 2980 deletions
26
devel/py-python-language-server/patches/patch-setup_py
Normal file
26
devel/py-python-language-server/patches/patch-setup_py
Normal file
|
@ -0,0 +1,26 @@
|
|||
Index: setup.py
|
||||
--- setup.py.orig
|
||||
+++ setup.py
|
||||
@@ -10,7 +10,7 @@ install_requires = [
|
||||
'configparser; python_version<"3.0"',
|
||||
'future>=0.14.0; python_version<"3"',
|
||||
'backports.functools_lru_cache; python_version<"3.2"',
|
||||
- 'jedi>=0.17.2,<0.18.0',
|
||||
+ 'jedi>=0.17.2',
|
||||
'python-jsonrpc-server>=0.4.0',
|
||||
'pluggy',
|
||||
'ujson<=2.0.3 ; platform_system!="Windows" and python_version<"3.0"',
|
||||
@@ -52,10 +52,10 @@ setup(
|
||||
'all': [
|
||||
'autopep8',
|
||||
'flake8>=3.8.0',
|
||||
- 'mccabe>=0.6.0,<0.7.0',
|
||||
- 'pycodestyle>=2.6.0,<2.7.0',
|
||||
+ 'mccabe>=0.6.0',
|
||||
+ 'pycodestyle>=2.6.0',
|
||||
'pydocstyle>=2.0.0',
|
||||
- 'pyflakes>=2.2.0,<2.3.0',
|
||||
+ 'pyflakes>=2.2.0',
|
||||
# pylint >= 2.5.0 is required for working through stdin and only
|
||||
# available with python3
|
||||
'pylint>=2.5.0' if sys.version_info.major >= 3 else 'pylint',
|
Loading…
Add table
Add a link
Reference in a new issue